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2. Preface 

The software supports three display modes: 

▪ SA/NX Series instruments: workstation one column (default), workstation two column, and 

tablet mode 

▪ PX Series instruments: Tablet mode 

This document uses the tablet mode in the software as an example to describe the interface 

layout, operating modes, and operation methods of the spectrum analysis software. Although 

the supported display modes vary among different instruments, the operation logic is 

consistent across all modes. The corresponding interface diagrams are shown below. 

 

Figure 1 Tablet mode interface display 

 

Figure 2 Workstation one column mode interface display 
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3. Preparation 

3.1 Software Compatibility 

The spectrum analysis software is compatible with the full range of SA, NX, and PX instruments 

running version 55. 

3.2 Operating Environment Requirements 

For the SA/NX series, which are kernel-based instruments, the spectrum analysis software 

must be installed on a host computer. The recommended operating environment for the host 

computer is shown in the table below: 

Only the basic recommended configurations are listed in the table. For systems below the 

recommended specifications, please refer to the actual test results. 

Table 1 System Operating Environment Requirements 

Operating System Windows 11/10/8/7, requires VS2019 C++ redistributables 

Ubuntu 22.04/20.04/18.04, Debian 12/11/10, Raspberry Pi OS 64-bit 

Architecture Windows: x64, AArch64 (only on NX devices) 

Linux: x64, AArch64 

Processor Windows: Intel i3 or above; AArch64 (tested on 8CX Gen2) 

Linux: Tested on Raspberry Pi 4B, Raspberry Pi 5, RK3399, RK3588, etc. 

Memory 4 GB or above 

Storage IQ recording requires sustained storage write speed >400 Mbytes/s 

Data Interface USB 2.0 or USB 3.0 (USB 3.0 recommended) 

IQ recording bandwidth and duration depend on interface bandwidth 

Display Resolution Not less than 1280 * 768 pixels 

Other Certain antivirus software may cause the system to malfunction 

3.3 Default Software Storage Paths 

For PXE-90/PXE-200/PXN-400 series instruments have their software installed by default in 

the desktop userdata directory; 

For PXN-45/PXN-60/PXN-90 series instruments have their software installed by default in the 

"/software" directory. 

For SA/NX series instruments, the software is installed in a user-defined directory. 

In the software directory, the "data", "images", and "reports" folders store different types of 

data respectively. 

▪ data folder: Recording files, Configuration files, and Spectrogram CSV data files 

▪ images folder: Chart images 

▪ reports folder: CSV files containing chart data and the corresponding configuration files  

Except for quick record/playback files and quick screenshots, all other recording files or images 

can be stored in a user-defined path (PX series instruments require an external storage device, 

while SA/NX series instruments can define the storage path directly). 
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3.4 Software Acquisition 

Please refer to the Software and Firmware Update section for instructions on obtaining and 

installing the latest version of the software. 

Note: By default, Windows x64, Linux x86_64 and Linux aarch64 versions of the software are 

provided. If a Windows x86 version is required, please contact official technical support for 

assistance.  
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4. Working Modes Overview 

Software offers working modes, including Standard Spectrum Analysis (SWP), IQ Streaming 

(IQS), Power Detection Analysis (DET), Real-time Spectrum Analysis (RTA), Phase Noise 

Measure, Basic Digital Demodulation (option), MSCAN mode and Mapping mode. The 

measurement functions available in each working mode will be explained in the following 

sections. 

4.1 Standard Spectrum Analysis 

In the standard spectrum analysis mode, the instrument performs frequency hopping 

according to the configuration to achieve frequency scanning. This mode is suitable for 

applications focused on frequency trace measurement and analysis. The measurement and 

analysis functions provided in the standard spectrum analysis mode include: 

◼ Spectrum Panoramic Sweep ◼ IM3 

◼ Local Spectrum Zoom Display ◼ Channel Power 

◼ Spectrogram ◼ OBW 

◼ Spectrum Recording and Playback ◼ ACPR 

◼ SEM ◼ Amplitude Correction 

◼ Peak and Signal Tracking ◼ Peak Table 

4.2 Receiver/IQ Streaming Mode 

In the IQ streaming mode, the instrument acquires time-domain data within the analysis 

bandwidth according to the specified trigger signal and returns it to the user. This mode is 

suitable for applications such as time-domain signal recording and basic demodulation analysis. 

The functions provided in the IQ streaming mode include: 

◼ IQ Time Domain Waveform ◼ Spectrum Analysis 

◼ Spectrogram ◼ AM/FM Demodulation 

◼ Power-Time Waveform ◼ Audio Analysis 

◼ Multi-Channel DDC ◼ IQ Data Recording and Playback 

◼ Pulse Signal Detection (option)  

4.3 Power Detection Mode 

In the detector analysis mode, the instrument performs continuous detection analysis on the 

time-domain signal within the analysis bandwidth. This mode is suitable for observing the 

relationship between time and power within a certain bandwidth, such as pulse parameter 

measurements. The functions provided in the detector analysis mode include: 

◼ Power-Time waveform and zoom ◼ DET Data Recording and Playback 

◼ Pulse Signal Detection (option)  
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4.4 Real-Time Spectrum Analysis Mode 

In the real-time spectrum analysis mode, the instrument performs real-time spectrum analysis 

on the time-domain signal within the analysis bandwidth and returns the spectrum results to 

the user. This mode is suitable for applications that focus on instantaneous and transient signals, 

such as interference troubleshooting and the identification of characteristic signals in complex 

electromagnetic environments. The functions provided in the real-time spectrum analysis 

mode include: 

◼ Real-time Spectrum Probability 

Density Graph and Spectrogram 

◼ Real-Time Spectrum Data Recording and 

Playback 

4.5 Harmonic Analysis Mode 

In the harmonic analysis mode, the instrument performs harmonic analysis on the signal based 

on its fundamental frequency and displays the frequency, amplitude, and the relative 

difference from the fundamental for each harmonic. This mode is suitable for analyzing 

harmonic distortion in signals and helps identify and evaluate their nonlinear characteristics. 

The functions provided in the harmonic analysis mode include: 

◼ Harmonic Spectrum Diagram ◼ Harmonic Measurement Table 

4.6 Phase Noise Measurement Mode 

In the phase noise measurement mode, the instrument uses automated measurement 

techniques to provide high-precision phase noise plots and detailed data tables, enabling 

users to thoroughly analyze the phase stability of a signal and the noise density at different 

frequency offsets. The functions provided in the phase noise measurement mode include: 

◼ SSB Phase Noise Spectrum Diagram ◼ Phase Noise Measurement Table 

4.7 Digital Demodulation Mode (Option 71) 

In the digital demodulation mode, the instrument supports demodulation of various modulated 

signals and evaluates their modulation quality from multiple perspectives. This function is 

suitable for a wide range of applications, particularly for in-depth analysis and quality 

assessment of known modulated signals. The functions provided in the digital demodulation 

mode include: 

◼ Constellation and Eye Diagram ◼ Bit Table and Demodulation 

◼ Modulated Signal Spectrum Analysis ◼ ASK/FSK/PSK/QAM Demodulation 

4.8 MSCAN Mode 

In MSCAN mode, the instrument allows users to customize measurement parameters for each 

frequency band and combine them into a configuration list. Once the list is configured, the 

device continuously acquires and displays spectrum data according to the defined settings. 

This feature is suitable for rapid preview and analysis of multi-band signals. 

◼ Multi-Band Spectrum Preview ◼ Spectrum Analysis 

◼ IQ Time-Domain Waveform ◼ Configuration List 
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4.9 Mapping Mode 

In Mapping mode, the instrument combines spectrum measurement data with synchronously 

acquired GPS geographic coordinate information to generate a visual heat map displaying 

signal strength, peak power, occupied bandwidth, and interference distribution. This mode is 

suitable for radio monitoring, signal surveys, interference analysis, and network optimization. 

The functions provided by Mapping mode include: 

◼ Georeferenced Map Import ◼ GPS Integration 

◼ Heatmap Generation ◼ Signal Analysis and Auto Measurement 

◼ Spectrum Display ◼ Measurement Results Table 

◼ Task Import/Export  

4.10 Application Software UI Layout 

The application software UI consists of the following sections: 

◼ Menu ◼ Graph Set Area 

◼ Graph Display Area ◼ Main Setting Area 

◼ Instrument State ◼ Parameter Quick Set 

 

Figure 3 Software Interface Layout 

4.10.1 Menu 

◼ Save and Load Configuration ◼ Set Startup State 

◼ Working Mode Switch ◼ Measurement Mode Selection 

◼ Single or Continuous Preview ◼ Recording and Playback 

◼ Quick Screenshot ◼ GNSS and Instrument Information View 

◼ Fan Control (SA/NX only) ◼ Display Mode Switch (SA/NX only) 
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4.10.2 Graph Set Area 

◼ Graph Settings ◼ Trace Settings 

◼ Marker Settings ◼ Display Measurement Results 

4.10.3 Main Settings Area 

◼ Measurement and Analysis Settings ◼ Trigger Settings 

◼ Data Recording and Playback ◼ System Settings 

4.10.4 Instrument State 

◼ GNSS Antenna Connections Status ◼ Instrument Model 

◼ Last Six Digits of Instrument UID ◼ API/FPGA/MCU Version 

◼ Software GUI Version ◼ Bus Data Throughput 

◼ Instrument Real-Time Temperature ◼ Instrument Power Level (PX only) 
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5. Common Operation 

5.1 Save and Recall Instrument Configuration 

1. Save the current configuration 

1). Click "File" -> "Save State" in the menu bar; 

2). In the "Save Configuration File" pop-up window, set the save path and file name, click 

"Confirm" to save the configuration file. 

2. Open pre-stored configurations 

1). Click "File" -> "Recall State" in the menu bar; 

2). Select the configuration file in the "Please select file" pop-up window, click "Confirm" to 

open the pre-stored configuration. 

5.2 Save the Pictures 

1. Click "File" -> "Save Image" on the menu bar; 

2. In the "Save Image" pop-up window, set the path to save the picture and the picture name, 

and click "Confirm" to save the screenshot. 

3. Users can also take screenshots by clicking the shortcut button "  " in the menu bar, the 

pictures are saved in the "/images" folder by default, and the storage path cannot be 

changed. 

5.3 Deleting files and images 

PXE-90/PXE-200/PXN-400 Series Instruments: In the corresponding storage folder under the 

software directory, drag and drop the target file to the "Trash Can", then click "Yes" in the 

confirmation dialog to delete it. (The deletion method for record files and configuration files is 

the same as for screenshots). 

PXN-45/PXN-60/PXN-90 Series Instruments: In the corresponding storage folder under the 

software directory, select the target file, then click "Edit" -> "Move to Trash" in the top menu bar. 

Finally, click "Yes" in the confirmation dialog to complete the deletion. 

 

Figure 4 PXE-90/PXE-200/PXN-400 Series Instruments Delete Picture 

5.4 Setting the Startup State 

The instrument supports user-defined startup states, the relevant startup state description is 

detailed in Table below. 
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Table 2 Upper computer software power on state 

No. Power On State  

1 Default Default configuration. 

2 User Preset Load a user-saved profile as the startup configuration. 

3 Last State Restore settings from the last session at startup. 

If you want to set the startup state, follow these steps. 

1. Click "File" -> "Power On State" in the menu bar; 

2. "Default" and "Last State" can be ticked directly, the software will take this option as the 

initial state when it starts next time; 

3. Select "User Preset", select the user's pre-saved configuration file in the "Please select file" 

pop-up window that appears, and the software will open with the specified configuration 

at the next startup. 

5.5 Switching Operating Modes  

Click "Mode" in the menu bar to switch between Standard Spectrum Analysis, Receiver/IQ 

Streaming, Power Detection, Real-Time Spectrum Analysis, Digital Demodulation (Option), 

Harmonic Analysis, Phase Noise Measurement, MSCAN mode and Mapping mode. 

5.6 Professional and Concise Settings 

Click "System" -> "Setting Mode" in the menu bar to switch between "Basic" and "Professional" 

modes. Compared to the Basic mode, the Professional mode provides more parameter options 

in the main settings area, allowing users to flexibly select the appropriate setting mode based 

on actual needs. 

5.7 Theme Settings  

Click "System" -> "Theme" in the menu bar to switch between "Dark" and "Light" themes. 

5.8 Parameter Settings  

Click "System" -> "Preference" in the menu bar, and you can set the following functions in the 

pop-up setting window: 

Table 3 Parameter Setting Parameter Description 

Parameter Description 

Haptics (PX only) When enabled, the instrument provides haptic feedback via 
vibration during touchscreen operations. 

Screen Lock When enabled, a lock icon "  " appears on the right side of the 
screen. Tap the icon " " to lock the screen and prevent accidental 
operations, tap again to unlock. 

Digital Det When enabled, reduces the refresh rate of certain displayed 
parameters (including marker) to aid observation and recording. 

Auto-Dim (PX only) When enabled, the instrument automatically lowers screen 
brightness if there is no operation for one minute. 

Brightness (PX only) Adjusts the screen brightness for PX series instruments. 

Volume (PX only) Adjusts the volume for PX series instruments. 
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Data/Time (PX only) When GNSS is not locked, the user can manually set the PX series 
system time. Once GNSS is locked, system time can be 
synchronized either by a one-time "Auto UTC Time" or continuously 
via "Sync UTC Time". 

Fan Control Standard: lower temperature threshold, more responsive. 
Quiet: higher threshold, smoother speed ramp. 

5.9 GNSS Usage 

This section provides detailed instructions on how to obtain real-time positioning data using 

either the built-in or external GNSS module. Here, the built-in module refers to the GNSS 

module independently developed by the company, while the external module refers to a GNSS 

module produced by other manufacturers that supports serial communication. In addition, it 

explains how to use the 1PPS trigger of the built-in GNSS module and the 10 MHz reference 

clock of the high-precision built-in GNSS module. 

Table 4 Description of GNSS parameters 

No. Parameter Description 

1 GPS Type Select internal or external GNSS module. 

2 Baud Rate Serial port baud rate for the external GNSS module. 
Required only when using an external GNSS module. 

3 Antenna Select Internal Antenna or External Antenna (Currently only external 
antenna is supported). Required only when using the internal GNSS 
module. 

4 XPPS Out On: Outputs the XPPS pulse signal 
Off: Forces the GNSS module’s XPPS output function to be disabled 

5 XPPS Adjust the output pulse frequency of the GNSS module, in Hz. 
Default value: 1 Hz, which outputs a 1PPS signal. If set to 0.5 Hz, a 
pulse is output every 2 seconds, i.e., a 0.5 PPS signal. 

6 Format Provides two formats: Local Time and UTC Time. 

7 SatNum Number of satellites currently positioned. 

8 SNR(Max) Maximum signal-to-noise ratio of positioned satellites. 

9 SNR(Min) Minimum signal-to-noise ratio of positioned satellites. 

10 SNR(Avg) Average signal-to-noise ratio of positioned satellites. 

11 Reference 
Frequency 
Offset 

Display the frequency offset relative to the 100 MHz reference clock. 

5.9.1 Using the Built-in GNSS module  

1. Click "System" -> "GNSS Info", and set "GPS Type" to "Internal GPS" and "Antenna" to 

"External" in the GNSS Info box; 

2. Wait 1 to 3 minutes for the GNSS to lock, you can judge whether the GNSS is locked or not 

according to the GNSS lock logo in the status bar information, after locking the GNSS lock 

logo is green, if it is grey, then it is not locked. see table 4 for the explanation of the 

parameters in the GNSS information pop-up window. 



 

HAROGIC SAStudio4 User Guide 12 

 

Figure 5 Locked GNSS external antenna 

5.9.2 1PPS Trigger Using Internal GNSS Module 

Only IQS mode, DET mode and RTA mode can use 1PPS trigger of GNSS module. This section 

will take IQS mode as an example and explain in detail how to configure the 1PPS trigger 

function of the GNSS module. 

1. Refer to the section on Using the Built-in GNSS module to ensure that the GNSS is locked; 

2. Click "Mode" -> "IQStreaming" to switch to IQS mode; 

3. Click "Next" -> "Trigger" in the main setup area, and set "TriggerSource" to "GNSS-1PPS" in 

the "Trigger" submenu to use the GNSS module 1PPS trigger. 

 

Figure 6 Triggered using GNSS 1 PPS 
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5.9.3 Using the 10 MHz Reference Clock from the Built-in GNSS Module 

Note: Available only high quality GNSS modules. 

1. Please refer to the section on Using the Built-in GNSS module to ensure that GNSS is locked; 

2. Set "DOCXO" to "LockMode" in the GNSS Info box, wait for 5-10 minutes, if "DOCXO 

Locked" appears in the GNSS Info box, OCXO is locked successfully; 

3. Set "RefCLKSource" to "Internal_Premium" and "RefCLKFreq" to "10MHz" under the System 

submenu in the main setup area. At this time, the reference clock source is OCXO. 

 

Figure 7 10MHz reference clock using high quality GNSS modules 

5.9.4 Using External GNSS module 

1． Connect the external GNSS module to the PC USB port of the PX series or SA/NX series 

instrument using a USB-to-serial cable; 

2． In the software, click "System" -> "GNSS Info"; 

3． In the popup window, set "GPS Type" to "External GPS"; 

4． Click the "Refresh" button in the "COM Device" column and select the newly recognized 

"ttyUSBX" or "COMX" device; 

5． Set the "Baud Rate" to the actual output of the GNSS module (e.g. "9600") and click the 

"Connect" button below; 

6． The instrument will parse and display the received GNSS positioning information, see Table 

4 for an explanation of the parameters in the GNSS information pop-up window. 
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Figure 8 Connecting an external GNSS module 

5.10 GPIO Output Level Control 

After connecting the instrument to the corresponding EIO expansion board, click "System" -> 

"GPIO" in the menu bar to control the output levels of different GPIO interfaces. "On" indicates 

a high level, and "Off" indicates a low level. The interface definitions of the EIO expansion board 

are shown in the table below. 

 

Figure 9 EIO Expansion Board Interface Diagram 

Table 5 EIO Expansion Board Interface Pin Description  

Pin Description 

1 GPIO0 

2 GPIO2 

3 GPIO4 

4 GPIO6 

5 GND 

6 GPIO1 

7 GPIO3 

8 GPIO5 

9 GPIO7 
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5.11 Viewing Instrument Information 

Click "System" -> "About" in the menu bar, the UID number and firmware version of the current 

instrument will be displayed in the pop-up window. 

5.12 Preset 

Click the "Preset" button in the menu bar to restore the current software configuration to the 

default initial state of the instrument. 

5.13 Single or Continuous Preview 

Single preview: click "Single", Continuous preview: click "Continu.". 

5.14 Quick Record and Playback 

▪ Recording: Click "Rec" to start recording data, and click "Stop" to stop recording. 

▪ Playback: Click "Play" in the menu bar to play back the last recorded data, and click "Pause" 

to pause the playback. Click the "Continu." button in the menu bar to resume normal data 

acquisition and display. 

5.15 Hide Panel 

Click the hide icon " " in the menu bar to hide the main settings menu and expand the display 

area. This function is only available in Tablet Mode. 

5.16 Y-Axis Scale Zoom 

Click "Graph" -> "Scale/Div" in the chart settings area to modify the dB value per division, 

thereby adjusting the vertical display range of the trace. 

For PX series instruments, the Y-axis scale can also be adjusted in the following way: 

Click the interactive mode button " " in the chart setting area, then use touch gestures on the 

touchscreen: 

▪ Spread two fingers vertically: Decrease the dB value per division; 

▪ Pinch two fingers vertically: Increase the dB value per division. 

5.17 Offset 

The display offset of the trace can be adjusted in any of the following ways: 

1. Click "Graph" -> "Offset" in the chart setting area, and enter the offset value in the offset 

setting interface, where a positive value indicates that the trace is offset downward and a 

negative value indicates that the trace is offset upward. 

2. Click " " in the chart settings panel to enable manual adjustment. Once enabled, press and 

drag the trace up or down to quickly adjust its display position. 

You can later restore the default position via "Graph" -> "Reset Scale". 

5.18 Switch X-Axis scale 

Click the chart display area "Graph" -> "XScale" to display the X-axis of the spectrum either in 

"Lin" (Linear) or "Log" (Logarithmic) mode. 

5.19 Display Line  

Click "Graph" -> "Line" to enable a configurable visual reference line. Set the "LinePos" value to 

adjust its position on the y-axis. 

5.20 Setting Chart Units 

Click "Graph" -> "Units" to set the display units of the graph, including dBm, dBmV, dBmA, W, V, 

A, dBuV, dBuA and dBpW. 
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5.21 Spectrogram 

Only the standard spectrum analysis, IQ streaming, and Real-Time spectrum analysis modes 

support the spectrogram display function. A description of each control in the spectrogram 

settings interface is provided in the table below: 

Table 6 Description of Spectrogram Controls 

Graph Setting Area 

Scan Depth The time length cached on the y-axis of the spectrogram 
Cache limit: 8000 lines of pixels 

Time Density The refresh rate of the spectrogram 
When set to 100, scrolls 100 lines of pixels per second 

Color Sets the color gradient for the spectrogram 

1. Click "Graph" -> "Spectrogram" to create a spectrogram corresponding to the spectrum; 

2. Click the Spectrogram, switch to the corresponding chart setting area of the 

spectrogram, and then click "Graph" to enter the spectrogram setting interface; 

3. "Export Image" can export the current spectrogram in PNG format to the "/images" folder, 

"DataExport" can export the current cached data not exceeding the scan depth to the 

"/data" folder in CSV format, and the exported data is sorted in reverse chronological 

order. 

 

Figure 10 Enable Spectrogram 

4. The Power range corresponding to the Spectrogram's Color Bar can be set by adjusting 

the "Offset" and "Scale/Div" parameters. The specific calculation rules are as follows: 

▪ Color Bar Upper Limit = "Ref.Level" + "Offset" 

▪ Color Bar Lower Limit = "Ref.Level" + "Offset" - 10 * "Scale/Div" 
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5.22 Export Data 

The PNG image or CSV data of the current chart can be exported in any of the following ways: 

Export as follows: 

1. Click "Graph" -> "DataExport" in the setting area of the chart where the data is to be 

exported; 

2. Click the right mouse button in the chart display area, open the shortcut menu, select 

"DataExport". 

▪ The "Image" option allows you to export the current chart as a PNG image file, which is saved 

to the "/images" folder by default; 

▪ The "Data" can export chart data to CSV file, default save to "/reports" folder. 

5.23 Record and Playback 

Please refer to table 6 for key parameters in record and playback function. The record file format 

description is provided in Appendix 1 through Appendix 5.  

Table 7 Record and playback parameter description 

Record  

RecordMode FixedPoints: Allows presetting the number of recording points, 
recording duration, and file size limit. The actual recording duration 
cannot exceed the set "file size limit". 
Adaptive: Requires manually controlling the recording duration of the 
file. (Note: In manual mode, the software will automatically stop 
recording if the file size exceeds the "file size limit") 

RecordTime Set the recording duration, only effective when the record mode is 
"FixedPoints" 

FileSizeLimit The storage size limit for a single recording file 

Diskcapacity The remaining and total disk capacity 

Play Back  

Last frame Rewind by one frame 

Next frame Fast forward by one frame. 

Back Rewind by multiple frames. 

Forward Fast forward by multiple frames. 

1. Data Recording 

1). Click "Record"-> "RecordMode" in the main setting area and select the desired record mode; 

2). Click "REC File Path" to set the storage location of the log files, the default path is "/data" 

folder, users can also customize the storage path; 

3). In "Fixed" mode, click "Record" to automatically record data of a preset size. In "Manual" 

mode, you can manually control the recording duration by clicking "Record" and "Stop". 

Automatically stops recording when the file size exceeds the file size limit. 

2. Data Playback 

1). Click "Play Back" -> "Open File" in the main setting area, and select the record file to be 

played back in the pop-up window. 

2). Click "Playback" to start playback, click "Pause" to stop playback, click "Stop" to exit the 
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playback interface to resume data acquisition, and enable Turn on "Auto Loop" to loop back 

the record file. 

5.24 Graph Zoom Function 

The chart zoom function can be used to view detailed information in a local region of a spectrum 

or time-domain plot. The instrument provides two zoom methods: Zoom scaling and magnifier 

zoom, allowing users to flexibly choose according to their needs. 

5.24.1 Zoom Function 

1. Spectrum Zoom (Only in SWP mode) 

1). Click "Graph" ->"Zoom"; 

2). Click to select "Spec zoom", click "Graph", set the frequency range to be zoomed in the 

pop-up submenu, or directly drag the zoom box and its edges in the spectrum graph to 

adjust the position and zoom area. 

 

Figure 11 Spectrum zoom in SWP mode 

2. Time Domain Zoom (Only in IQvT, PvT, and DET Modes) 

1). IQvT and PvT 

In IQS mode, click "IQvT" or "PvT" in the main setting area, select the corresponding channel, 

open "Analyze" and "Zoom". Open "Analyze" and "Zoom", adjust the zoom area by holding down 

the zoom area and sliding the zoom frame, or holding down the zoom border and dragging it 

left and right. 

2). DET mode 

a) Click on "Graph" and open "Zoom" in the pop-up submenu; 

b) Slide the zoom frame by holding down the zoom area, drag the zoom border left and right, 

select the zoom graph "PvT Zoom", and click "Graph" to set the "TimeCenter" and 

"TimeRange". You can adjust the zoom area. 

  



 

HAROGIC SAStudio4 User Guide 19 

5.24.2 Magnifying Glass Function 

1. Click on the magnifying glass button " " to frame the area of interest; 
2. A thumbnail view will be displayed in the upper right corner of the main interface, showing 

the complete trace and the position of the zoomed-in area in the global picture; 

3. You can quickly switch the position of the zoomed-in area by dragging the red box in the 

thumbnail, or you can re-select a new area to zoom in; 

4. Click the Zoom button again to exit the zoomed-in view and restore the original trace 

display. 

 

Figure 12 Magnifying Glass Zoom in SWP Working Mode 

5.24.3 Interactive Zoom(PX series only) 

Click the interactive mode button " " in the chart setting area, then use touch gestures on the 

touchscreen: 

▪ Swipe left or right with one finger: Adjust the center frequency; 

▪ Spread two fingers horizontally: Decrease the span; 

▪ Pinch two fingers horizontally: Increase the span. 

5.25 Trace settings 

Click on "Trace" in the chart settings area and see the following table for a description of the 

parameters in the additional menu: 

Table 8 Trace Control Parameter Description 

Trace 

Enabled On: Turn on the traces of the corresponding labels, the upper limit is 4. 

Type ClearWrite, MaxHold, MinHold and Average 

Avg Setting the average number of times the average type of trace is 
averaged 
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StateReset Clears the current trace data and restarts the display according to the 
set trace type. 

Edit Lable Modify trace name for user to edit and manage multiple traces. 

Max/Avg/C&W Simultaneously enable three traces for MaxHold, Average and ClearWrite 

Max/Avg/Min Simultaneously enable three traces for MaxHold, Average and MinHold 

Reset Resets the trace display method, clears all current trace data, and reverts 
to the default clear write type 

5.26 Maker Function 

5.26.1 Create Markers 

1. Create a Marker 

Double-click on the chart display area, or click on "PeakSearch" in the chart settings area to 

quickly bring up the reference marker. 

2. Create multiple Markers 

Click the "Marker" submenu in the Chart Settings area, select the marker you want to create, 

and then click "Enable" to enable the selected marker. 

5.26.2 Create Marker Pairs 

Marker pairs can be created in any of the following ways (reference marker and difference 

marker as a group, current limit 5 groups): 

1. In the "Marker" submenu, select the marker pairs you want to create (e.g., "M1R" and "M1D") 

and click on "Enable"; 

2. Right-click on the chart display area to open the shortcut menu and select "Create marker 

pair"; 

3. Click "Graph" -> "Marker Pair" in the Graph Settings area to quickly enable a pair of reference 

marker and difference marker, and click continuously to enable multiple pairs of markers. 

5.26.3 Close Markers 

1. Close a Single Marker 

In the "Marker" submenu, select the marker you want to disable and click "Enable" to disable the 

selected marker. 

2. Close all Markers 

All currently enabled markers can be cleared in one of the following ways. 

1). Click "Graph" in the Chart Settings area and select "Clear All" in the pop-up window; 

2). Click the right mouse button in the chart display area, open the shortcut menu, select "Clear 

all markers". 

5.26.4 Change Markers Frequency 

1. Manual Enter Frequency Value 

Click "Marker" submenu, select an enabled marker (e.g. M1R, M2R), click the "Freq:" area on the 

top of the pop-up window, and set the marker frequency value. 

2. Drag Marker or Click to Jump 

1). Drag Marker: press and hold the marker and drag it to the desired position and then release 

it; 
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2). Click to Jump: select the marker, then double-click on the target frequency point; the 

marker will automatically jump to that position. 

5.26.5 Marker switching traces 

Switching the marker trace can be achieved using either of the following methods: 

1. Click "Marker" in the chart device area, select the target trace (e.g. switch from T1 to T2), the 

marker will automatically jump from T1 to the corresponding frequency position of T2; 

2. Right-click on the graph display area to open the context menu and select "Marker trace" 

to switch the target trace associated with the current marker. 

5.26.6 Delta Marker 

The delta marker must be used together with a reference marker to indicate the frequency 

difference, time difference, and amplitude difference relative to the reference marker. 

 

Figure 13 Enable Delta Marker 

5.26.7 Noise Density 

After creating the marker, turn on "NoiseDensity" in the "Marker" section of the chart settings 

area to convert the original power values to power density per Hz. 

5.26.8 Marker Peak Search 

1. Local peak search 

Double-click on the chart near a local peak, or select the marker and click "Marker" -> "Local 

Peak". 

2. Global peak search 

Click on "Peak Search" in the graph setting area to enable global peak search. 

3. Left and right peak search 

1). Enable Auto Parameter Setting 

After enabling the cursor, click "Marker" -> "Left Peak" / "Right Peak" in the chart setting area. 

By default, "AutoParam" is enabled, and the software will calculate appropriate peak thresholds 
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and peak offsets based on the noise floor and signal distribution of the current trace, so as to 

accurately identify valid local peaks. 

2). Set Custom Peak Threshold and Peak Offset 

After the marker is enabled, click "Marker" -> "Advanced" in the chart setting area, set the 

"Threshold" and "Excursion" for left and right peak searching. After that, click "Left Peak" or 

"Right Peak", when a qualified signal is detected, the marker will automatically locate to the 

signal position. 

▪ Peak Excursion: the minimum amplitude difference (dB) between the peak and the troughs 

on either side, used to determine if the peak is sufficiently prominent. 

5.26.9 Marker to Center 

The Marker to Centre function aligns the frequency of the current reference marker to the 

center of the chart, which can be achieved in any of the following ways: 

1. After moving the reference marker to the target frequency point, click "Marker" -> "to 

Center" in the chart setting area; 

2. After moving the reference marker to the target frequency point, click the right mouse 

button on the chart display area, open the shortcut menu and select "Marker to center". 

5.26.10 Marker Switch to Mode 

The Marker to Mode function quickly switches to other operating modes and sets the 

frequency at which the current reference marker is located as the center frequency of the new 

mode. This function can be realized in any of the following ways: 

1. After moving the reference marker to the target frequency point, click "Marker" -> "Switch 

to" in the chart setting area, and select the target mode; 

2. After moving the reference marker to the target frequency point, click the right mouse 

button in the chart display area, open the shortcut menu, select "Marker to Mode", and 

select the target mode. 

5.26.11 Signal tracking 

Signal tracking supported in standard spectrum analysis mode only. 

1. Click "Marker" in the chart setting area, in the pop-up submenu, click "More", and then click 

"Advanced". Set the "Threshold" and "Shake Range" for the tracking signal (when the peak 

frequency jitters within this range, the frequency value will not be frequently aligned to the 

center position); 
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Figure 14 Set the Peak Threshold and Shake Range 

2. Click "Signal Track", the reference marker will search for peaks within the span at this time, 

and align the peak signal to the center frequency, when the frequency of the target signal 

drifts, the spectrometer will automatically adjust its own center frequency, so that the signal 

is always located in the center of the chart display area, which is convenient for the user to 

observe and analyze. 

 

Figure 15 Frequency Tracking 

Note: In general, this function only moves the frequency position and does not change the span. 

However, it is difficult to continue tracking signals with particularly large drift beyond the 

current span; for signals at the edge of the instrument's scanning range, because of frequency 

limitations, the span will be further reduced. 
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5.26.12 Peak tracking 

Click "Marker" -> "Peak Tracking" in the chart setting area. After enabling, the cursor will 

automatically locate and continuously track the maximum peak within the current sweep span. 

When the signal amplitude or frequency changes, the cursor position will update in real time, 

allowing the user to continuously observe variations in signal amplitude. 

Note: The peak tracking function is only effective within the currently set sweep span. If the 

signal goes beyond this range, tracking will no longer continue. 

5.26.13 Peak table 

The Peak Table function is only supported in Standard Spectrum Analysis Mode: 

1. Click "Marker" in the chart settings area. In the pop-up submenu, click "More", then 

"Advanced". Set the threshold for the Peak Table. For detailed setup instructions, see the 

Signal Tracking section; 

2. Click "Peak Table". The instrument will automatically detect and mark peak points that 

exceed the threshold within the current sweep span (up to 10 peaks). These peaks are listed 

in the Peak Table below the display area, showing the frequency and power of each peak in 

descending order of signal power, allowing users to quickly identify the main signals in the 

spectrum. 

 

Figure 16 Peak Table 

5.27 Quick Parameter Setting 

5.27.1 Parameter setting 

Currently, quick settings are supported for the following commonly used parameters: 

Reference Level, RBW, VBW, Detector, Start frequency, Stop frequency, Span, Center 

frequency and other parameters. Users can tap the corresponding parameter on the screen 

and directly enter a value to modify it. 
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Figure 17 Setting Quick Parameters 

In addition to entering values, the center frequency and span can also be quickly modified in 

the following ways: 

▪ Center Frequency: Click the interactive mode button " " in the chart settings area, then 

press and drag the trace left or right. 

▪ Span: Click the interactive mode button " " in the chart settings area, then scroll the mouse 

wheel. (Note: This quick method is supported in GUI version 3.55.28 and above.) 

5.27.2 Parameter display 

In addition to the quick parameterization, this area also supports the display of some of the key 

parameters during the measurement: 

▪ SWT: Scan time for a single trace in the current configuration 

▪ Amp: Preamplifier enabled status 

▪ Spurious Suppression Label: Displays the spurious suppression mode in the current 

configuration (Note: Supported when GUI version is 3.55.26 and above) 

⚫ "S" Indicates Standard Spurious Rejection 

⚫ "E" Indicates Enhanced Spurious Suppression 

⚫ Blank Indicates spurious suppression is not enabled 

▪ Speed: the width of the spectrum swept per unit time in the current configuration (Hz/s) 

5.28 Modifying the IQSampleRate 

In IQ streaming mode, click "BW" in the main setup area and modify the value of "IQSampleRate" 

in the submenu to modify the sampling rate of the instrument. 
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5.29 Amplitude Correction 

To ensure the accuracy and repeatability of spectrum measurements, the instrument provides 

an amplitude correction function, which supports the user to compensate by manually 

inputting external gain/loss and importing the frequency response correction table. Currently, 

the amplitude correction function is only supported in spectrum analysis mode. 

5.29.1 Correction Rules 

▪ Between the start frequency and the first compensation point in the current span, 

compensation is performed according to the offset value of the first frequency point; 

▪ Between multiple compensation points, compensation is performed by linear interpolation 

based on the frequency data in the correction table; 

▪ Between the last compensation point and the termination frequency, according to the 

offset value of the last frequency point. 

5.29.2 Amplitude Correction Example 

Take the 1 GHz to 3 GHz band to compensate for -20 dB, the 3 GHz to 5 GHz band to perform 

-20 dB to +10 dB interpolation compensation, and the 5 GHz to 7 GHz band to compensate for 

10 dB as an example, the operation steps are as follows: 

1. Click "Frequency" and set "Start Frequency" to "1 GHz" and "Stop Frequency" to "7 GHz"; 

2. Click "System" -> "Amplitude Correction" in the menu bar; 

3. Enable the amplitude correction function in the pop-up window, and then click "Add" to add 

one frequency correction item at a time; 

4. Set Frequency 1 to "3 GHz" and Offset 1 to "-20 dB", click "Add" again and set Frequency 2 

to "5 GHz" and Offset 2 to "10 dB"; 

5. Click "Apply" in the bottom right corner of the pop-up window to apply the amplitude 

correction function; 

 

Figure 18 Amplitude correction application 
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6. Users can export the current correction configuration to an Excel table file via "Export" in 

the pop-up window, and the default export is to the "/data" folder; 

7. The user can also customize the amplitude correction table according to the format of the 

exported configuration and import it using the "Import" button. 

5.30 Display modes (only in SA/NX series) 

The upper computer software of SA/NX supports three display modes: workstation single-

column (default), workstation dual-column, and flat-panel mode; PX series instruments only 

support flat-panel mode. Users can choose the appropriate display mode according to their 

own needs. 

Table 9 Display Mode Lookup Table 

Display Mode Description 

Workstation  
One Col 

Single-column parameter display, providing more spectrum display 
space for focused spectrum observation. 

Workstation  
Two Col 

Two-column parameter display, allowing more convenient parameter 
settings and simultaneous viewing/comparison of multiple parameters. 

Tablet Suitable for tablets and other mobile devices, featuring a clean interface 
and easy touch operation. 

5.31 Fan Control (only in SA series) 

SA series instruments support users to set the instrument fan status, click "System" -> "Fan 

Control" in the menu bar to set the fan status, see the following table for status details. (Note: 

Turning off the fan for a long period of time may cause the device to overheat, thus affecting 

the performance and service life, so please use the function of turning off the fan forcibly with 

caution). 

Table 10 Fan Status Lookup Table 

Fan Control Descriptions 

On Turn on the fan. 

Off Turn off the fan. 

Auto Default mode. The fan is intelligently controlled, and automatically turns 
on when the device temperature reaches 50 oC, and automatically turns 
off when it drops to 40 oC. (SAE/SAN-400 series instruments have the fan 
on by default, not programmable) 

 

  



 

HAROGIC SAStudio4 User Guide 28 

6. Using of the SWP mode 

This section highlights some of the important parameters and test methods of the standard 

spectrum analysis model. 

6.1 Introduction to the General Parameters of the SWP Mode 

The important parameters of the SWP mode are described in Table below. 

Table 11 Description of SWP Mode Parameters 

Frequency 
 

LO Optimize Auto: default low spurious mode; 
Speed: high sweep speed mode; 
Spur: low spurious mode; 
PhaseNoise: low phase noise. 

Amplitude 
 

PreAmplifier Set the operation of the preamplifier: 
Auto On: The preamplifier turns on automatically when the reference 
level is below approximately -30 dBm. 
Forced Off: The preamplifier remains off regardless of the reference 
level. 
Low Gain: The preamplifier operates in low gain mode. 
Medium Gain: The preamplifier operates in medium gain mode. 
High Gain: The preamplifier operates in high gain mode. 

GainStrategy LowNoise: Focuses on low noise while keeping the noise floor flat. 
HighLinearity: Focuses on high linearity while keeping the noise floor 
flat. 

IFGainGrade 0 to X steps, 3 dB gain difference per step 
Increasing IF Gain Step: Reduces RF gain, raises noise floor, improves 
linearity, and reduces spurs. 
Decreasing IF Gain Step: Increases RF gain, lowers noise floor, 
reduces linearity, and increases spurs. 

Atten Step size 3 dB 
Atten = -1 dB (default): No attenuation. 
Atten ≥ 0 dB: Attenuation is enabled. 

Amplitude Offset Adjusts the amplitude range of the signal displayed on the spectrum 
analyzer without changing the actual signal value. By setting an 
offset, the displayed result on the device is modified. 

Auto Reference Available only in standard spectrum analysis mode. 
When enabled, the instrument automatically adjusts the reference 
level to ensure the signal trace is displayed within an appropriate 
range, preventing overload or an excessively low display. 

IFAGC IF AGC Control 
On: Reduces IF gain when saturation occurs to prevent overload. 
Off: Disables automatic gain control. 

AGC Target When IF gain control is enabled, set the target power for IF AGC: 
range is 0 to −30 dBFS; the Target represents the dBFS level relative 
to ADC saturation. 
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IF Out IF Output Control: 
On: Enables IF output. 
Off: Disables IF output. 

Antenna Factor Used to compensate for the antenna’s gain or attenuation, in order to 
convert the signal received by the antenna into the actual electric 
field strength. 

Sweep 
 

SWTMode min SWT: minimum sweep time; 
min SWTx2: approximately 2 times of min SWT; 
min SWTx4: approximately 4 times of min SWT; 
min SWTx10: approximately 10 times of min SWT; 
min SWTx20: approximately 20 times of min SWT; 
min SWTx50: approximately 50 times of min SWT; 
min SWTxN: approximately N times of min SWT, 
N = SweepTimeMultiple; 
Manual: approximately equal to the target SweepTime. 

PointsStrategy SweepSpeed: priority is given to the fastest sweep speed; 
PointsAccuracy: priority is given to ensuring that the number of trace 
points is close to the target. 

SpurRejection Bypass, Standard and Enhanced. 

FFTExecution Auto: automatically selects the CPU or FPGA for FFT calculation 
based on the settings (using CPU for RBW below 30 kHz and FPGA 
for RBW above 30 kHz), CPU preferred, FPGA preferred, CPU Low 
Occ, CPU Mid Occ, CPU High Occ, FPGA only. 

Window FlatTop Window: higher amplitude accuracy. 
B-Nuttal Window: greater frequency selectivity. 
LowSideLobe Window: higher accuracy in measuring low-frequency 
signals. 
Rectangular Window: highest frequency resolution. 

Kaiser Window: β = 7.6. 

System 
 

RefCLKSource 
 
 
 
 
 

When using an external reference clock source, set the reference 
clock frequency to 10MHz. 
Internal: Use the internal reference clock. 
External: Use the external reference clock; if unavailable, 
automatically switches to the internal clock. 
External_Forced: An external reference clock must be connected. If 
not, the system will not switch to the internal clock, and an unlocked 
clock may result in unstable received signals 

RefCLKOut All-New PXN and SAN series: When enabled, outputs a 100 MHz 
reference clock. 
Others: When enabled, outputs a 10 MHz reference clock. 
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6.2 Channel Power 

As an example, a BPSK signal with a carrier frequency of 1 GHz, a power of -20 dBm and a 

symbol rate of 1 MHz is tested. 

6.2.1 Parameters description 

Only some of the important parameters are described here: the important parameters in the 

channel power measurement section are shown in Table below. 

Table 12 Description of Channel Power Measurement Parameters 

Channel Power  

Meas BW The bandwidth of the channel to be measured; channel power is 
the integrated power within this bandwidth. 

SpanPower The measurement bandwidth to the current span and calculates 
the channel power within this range. 

6.2.2 Procedure 

1. Set "Center" to 1 GHz and "Ref.Level" to 0 dBm, click "Meas" menu and select 

"ChannelPower"; 

2. The software will automatically configure the default parameters, and the test results are 

shown below. The upper left corner of the measurement box shows the channel power 

value. In the lower "ChannelPower" column, you can also view the Meas BW, ChannelPower 

and Power Density values; 

3. You can adjust the channel center frequency (press and hold the measurement area and 

slide to select), measurement bandwidth (press and hold the measurement border and 

drag left and right or adjust the Meas BW setting), and also modify the parameters such as 

"Center", "Span", "Ref.Level" and "RBW" in the main setting area to suit different signals. 

 

Figure 19 Measurement of ChannelPower 
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6.3 Occupied Bandwidth 

As an example, a BPSK signal with a carrier frequency of 1 GHz, a power of -20 dBm and a 

symbol rate of 1 MHz is tested. 

6.3.1 Parameters description 

Only some of the important parameters are described here: some of the important parameters 

of the occupied bandwidth measurement are shown in Table below. 

Table 13 Description of OBW Parameters 

OBW 

Method XdB, Percentage 

XdB/% Set specific XdB values/percentages 

6.3.2 Procedure 

1. Set "Center " to 1 GHz and "Ref.Level" to 0 dBm, click "Meas" menu and select "OBW" in the 

submenu; 

2. Click on "BW" and set "RBW" to 50 kHz; 

3. The software will automatically configure the measurement parameters, and the 

measurement results are shown in the figure. You can see the occupied bandwidth value in 

the lower "OBW" column; 

4. You can also modify the parameters such as "Center ", "Span", "Ref.Level" and "RBW", etc. in 

the main setup area to suit the measurement of different signals. 

  

Figure 20 Measurement of OBW 
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6.4 Adjacent Channel Power Ratio (ACPR) 

As an example, a BPSK signal with a carrier frequency of 1 GHz, a power of -20 dBm and a 

symbol rate of 1 MHz is tested. 

6.4.1 Parameters description 

Only some of the important parameters are described here: some of the important parameters 

of the adjacent channel power ratio measurement are shown in Table below. 

Table 14 Description of ACPR Measurement Parameters 

ACPR 

Space Setting the frequency interval between the main channel and the 
adjacent channel. 

Count Set the number of adjacent pairs, upper limit 2 pairs. 

6.4.2 Procedure 

1. Set "Center" to 1 GHz and "Ref.Level" to 0 dBm, click "Meas" menu and select "ACPR" in the 

submenu; 

2. The software will automatically configure the default parameters and the test results are 

shown below. The top green channel bandwidth is the power value of each channel. You 

can also check the Adj Center, Adj Power and Adj Ratio in the "ACPR" column at the bottom; 

3. You can set the center frequency of the main channel, the bandwidth of each channel, the 

adjacent channel spacing and the number of adjacent channel pairs, and you can also 

modify the parameters such as "Center", "Span", "Ref.Level" and "RBW", etc. in the main 

setting area to suit the measurement of different signals. 

 

Figure 21 Measurement of ACPR 
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6.5 IP3/IM3 

Example of testing IP3/IM3 at the 1 GHz frequency point. 

6.5.1 Parameters description 

Only some of the important parameters are described here: Some of the important parameters 

for IP3/IM3 measurements are shown in Table below. 

Table 15 Description of IP3/IM3 Measurement Parameters 

IP3/IM3 

LowTone 
Frequency/Power 

Frequency/Power of the input low-frequency signal. 

HighTone 
Frequency/Power 

Frequency/Power of the input high-frequency signal. 

LowIM3P 
Frequency/Power 

Frequency/Power of the intermodulation-generated low-side signal. 

HighIM3P 
Frequency/Power 

Frequency/Power of the intermodulation-generated high-side signal. 

TonePowerDiff High and low frequency power difference of the input signal. 

6.5.2 Procedure 

1. Combine the signals with a center frequency of 999 MHz and an amplitude of 0 dBm and a 

center frequency of 1.001 GHz and an amplitude of 0 dBm into a single signal by means of 

two signal sources and combiners, and input them into the instrument; 

2. Set the "Center" of the instrument to 1 GHz and the "Ref.Level" to 0 dBm, click the "Meas" 

menu and select "IM3"; 

3. Adjust the signal power so that the third-order intermodulation interference signal appears 

approximately 6 dB below the reference level in the spectrum; 

4. The software will automatically configure the default parameters and the test results are 

shown below. The IP3 test results can be viewed in the "IM3" column below. 

 

Figure 22 Measurement of IP3/IM3 
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6.6 SEM 

The Spectrum Emission Mask (SEM) is a measurement function used to evaluate whether a 

wireless signal has excessive emissions or spurious signals outside its operating frequency 

band. 

As an example, this function can be used to assess whether an IEEE 802.11ac signal with a 

frequency of 1 GHz and a power level of -20 dBm complies with the standard. 

6.6.1 Parameters description 

Only some of the important parameters are described here: some of the important parameters 

for SEM measurements are shown in Table below. 

Table 16 Description of SEM Measurement Parameters 

SEM 

Auto Set Linkage with peak reference type, automatically using the signal peak as the 
current relative reference when enabled. 

Ref Set Type Manual: When enabled, user-defined relative reference level. 
Peak: When enabled, the peak of the current signal is used as the relative 
reference level. 

Manual Ref Sets the relative reference level value. This function only works when 
"Manual" is selected as the reference type The set manual reference value will 
be used as the reference for calculating the start/stop threshold in the offset 
table. 

Offset Table StarFreq/StopFreq Set the upper offset band to indicate the offset 
distance relative to the center frequency. The system 
automatically generates upper and lower offset 
bands symmetrical to the center frequency, and up to 
16 offset bands can be configured. 

LimitStart/LimitStop Setting the power limit of the signal in the 
corresponding upper and lower offset bands 

Mode Absolute: Measurement in absolute amplitude, based 
on the actual power value, independent of the 
reference value. 
Relative: Measurement relative to a set "Manual" 
value, based on the reference value to calculate the 
power limit in the offset band. 

Priority Required: must meet the requirements of the 
template, if not, it will be regarded as a failure. 
Suggested: recommended to meet the requirements 
of the template, if not, then prompt a warning. 

Save Table Save the current measurement template  
Default path: "/data". 

Load Table Load user pre-stored measurement templates 
Load Preset Select the appropriate template from the predefined 

templates provided with the device Template type: 
802.11a/g, 802.11b, 802.11n (20MHz, 40MHz), 802.11ac 
(20MHz, 40MHz, 80MHz, 160MHz) AM NRSC, FM FCC 
73.317, FM NRSC Hybrid, AM NRSC 5K Hybrid, AM 
NRSC 8K Hybrid, Bluetooth 

Export Result 
Export the measurement table below the trace as a table 
Default path: "/reports". 
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6.6.2 Procedure 

1. Set the "Center" to 1 GHz and the "Ref.Level" to -20 dBm; 

2. Click "Meas" and select "SEM" in the additional menu; 

3. Click "Offset Table", select the "Load Preset" button in the pop-up window, and select the 

"802.11ac (20MHz)" template in the template list; 

4. Click "BW", adjust "RBW" to "5 kHz" and "VBW Mode" to "VBW = 0.01 RBW"; 

5. Click "Sweep", set "SWTMode" in the additional menu to "minSWT×20", and set "Detector" 

to "Average"; 

6. The measurement results are shown in the figure below, the spectrum map will show 

whether this spectrum meets the requirements of the template, and the maximum margin 

on each offset band is shown in the table below the measurement results. 

 

Figure 23 Measurement of SEM 

6.7 Auto Reference Level 

The Auto Reference Level function is used to automatically adjust the reference level of the 

instrument to ensure that the signal trace is within the appropriate display range to avoid the 

signal being out of range or displayed too low. 

The following is an example of adjusting the power adjustment of a 1 GHz single tone signal: 

1. Input a signal with a frequency of 1 GHz and a power of -35 dBm into the instrument; 

2. Set the "Start Frequency" to 90 MHz and the "Stop Frequency" to 3 GHz; 

3. Click "Amplitude" in the menu bar to enable the function of "Auto Reference Level"; 

4. The system will automatically adjust the reference level from 0 dBm to -30 dBm; 

5. Modify the input signal power to 5 dBm, the reference level will be adjusted from -30 dBm 

to +10 dBm. 

Note: The lower limit of the automatic reference level threshold is -70 dBm, the adjustment step 

is 10 dB/grade, the input signal should not exceed the corresponding loss power of each 

frequency band. 
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Figure 24 Enable Automatic Reference Level 

6.8 Antenna Factor 

In software versions 3.55.28 and above of the GUI, the Antenna Factor function has been added. 

It is used to compensate for the antenna's gain or attenuation and to convert the signal received 

by the antenna into the actual electric field strength. 

6.8.1 Parameters description 

Only some key parameters are explained here: the main parameters of the antenna factor are 

shown in Table below. 

Table 17 Description of Antenna factor Parameter 

Antenna Factor 

Enable On: Activates the Antenna factor function. 

Import 
Allows users to customize the Antenna Factor configuration 
according to the exported file format and import it into the system. 

Export 
Exports the current Antenna Factor configuration as an Excel file, 
with the default export path set to the "/data" folder 

Apply 
After setting or updating the Antenna Factor configuration, click the 
Apply button to make the configuration take effect 

Load 
When paired with the HDA-100 active directional antenna, no 
configuration is required and the antenna factor is loaded at a button 

6.8.2 Compensation Rules 

▪ From the start frequency to the first compensation point within the current sweep span, 

compensation is applied using the factor of the first compensation point; 

▪ Between multiple compensation points, compensation of the antenna factor is performed 

using linear interpolation based on the frequency point data in the correction table; 

▪ From the last compensation point to the stop frequency, compensation is applied using 

the factor of the last compensation point. 
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6.8.3 Antenna Factor Configuration Example 

For example, to configure compensation as follows: 17.5 dB for the 30 MHz to 50 MHz band, 

linear interpolation from 17.5 dB to 27.3 dB for the 50 MHz to 1 GHz band, and 27.3 dB for the 1 

GHz to 2 GHz band, proceed with the following steps: 

1. Click "Frequency", set "Start" to 30 MHz and "Stop" to 2 GHz; 

2. Click "Amplitude" -> "Antenna Factor" in the menu bar; 

3. In the pop-up window, enable "Enable", then click "Add". Each click allows you to add one 

frequency correction entry; 

4. Set "Frequency 1" to "50 MHz" and "Factor 1" to "17.5 dB". Click "Add" again, then set 

"Frequency 2" to "1 GHz" and "Factor 2" to "27.3 dB"; 

5. Click "Apply" in the bottom-right corner of the pop-up window to apply the antenna factor 

compensation; 

6. Users can also click "Export" to export the current configuration as an Excel file, which is 

saved by default in the "/data" folder; 

7. If using antenna factor data provided by the manufacturer, you need to generate a 

correction table in the same format as the exported file so it can be recognized by the 

software, and then import it using the "Import" button. 

 

Figure 25 Antenna Factor Configuration Example 

6.8.4 Auto Load Antenna Factor 

When paired with HDA-100 active directional antenna, there is no need to manually configure it, 

the system can automatically load the antenna factor, thus enhancing work efficiency. The 

specific steps are shown below: 

1. Correctly connect the instrument and HAD-100 active directional antenna, and start the 

software; 

2. Set the "Start Frequency" to 500 MHz and the "End Frequency" to 10 GHz; 

3. Click "Amplitude" -> "Antenna Factor" in the menu bar; 

4. Enable "Enable" in the pop-up window, and then click "Load", the system will load the 

antenna factor automatically. 
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Figure 26 With HDA-100: automatic loading of antenna factors  
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7. Using of the IQS mode 

This chapter describes in detail some of the important parameters of the IQ streaming mode, 

and focuses on describing how to carry out further analyses of the time-domain IQ data 

acquired by the system, such as spectral analysis, time-domain analysis, power-time analysis, 

digital down-conversion, demodulation, etc. 

7.1 Introduction to the General Parameters of The IQS mode 

Table 18 Description of IQS Mode Parameters 

Frequency 

LO Optimize Please refer to the parameter with the same name in the 
Introduction to the General Parameters of SWP Mode. 

BW 

IQSampleRate ADC sampling rate, 110 MSPS to 130 MSPS can be set. 

AnalysisBw Display the equivalent sampling rate after extraction: Span * 
0.8. 

Span▲/▼ Support increasing or decreasing the analysis bandwidth in 
powers of two. 

DataFormat 8-bit: Lower precision. When there is no signal, many zeros 
are likely to be captured. 
16-bit: Default configuration. 
32-bit: Higher precision. 

Amplitude 

PreAmplifier Please refer to the parameter with the same name in the 
Introduction to the General Parameters of SWP Mode. 

GainStrategy 

IFGainGrade 

Atten 

AmpOffset 

IFAGC 

IFAGCTarget 

IFOut 

Current IF Gain Unit: dB. Returns the current IF AGC gain, where positive 
values indicate amplification and negative values indicate 
attenuation. 

Record 

RecordMode Please refer to the parameter with the same name in the 
Recording and Playback. 

RecordTime 

FileSizeLimit 

Diskcapacotu 
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Playback 

Last frame Please refer to the parameter with the same name in the 
Recording and Playback. 

Next frame 

Back 

Forward 

System 

RefCLKSource Please refer to the parameter with the same name in the 
Introduction to the General Parameters of SWP Mode. 

RefCLKOut 

7.2 IQ Streaming Working Mode Overview 

The initial interface of the IQ Stream Mode consists of a Max Power vs. Time thumbnail, a 

spectrum plot, and a time-domain plot. Click "Next" in the main settings area, then click "Trigger". 

In the submenu, modify the "Preview Time" parameter to adjust the preview time range of the 

IQ stream in the Max Power vs. Time thumbnail. 

The display ranges of the spectrum plot and the IQ time-domain plot are determined by the red 

selection boxes, "Spectrum-P" and "IQvT-P", in the Max Power vs. Time thumbnail. By adjusting 

the position and range of these selection boxes, you can observe IQ time-domain signals from 

different time segments, or perform spectrum analysis on IQ time-domain signals captured 

over different time periods. 

7.3 Spectrum Analysis 

7.3.1 Parameters description 

Only some of the important parameters are described here: the important parameters in the 

spectrum analysis section are shown in Table 18. 

Table 19 Description of Spectrum Analysis Parameters 

Spectrum analysis 

Window Please refer to the parameter with the same name in the Introduction 
to the General Parameters of SWP Mode. 

Intercept Spectrum interception: e.g. Intercept = 0.8, displays 80% of the FFT 
spectrum analysis results in order to intercept the transition band 
spectral components 

7.3.2 Procedure 

1. Click "FFT" in the main settings area and enable "Analyze". Drag the red selection box 

"Spectrum-P" in the Max Power vs. Time thumbnail, or adjust the values of "TimeStart" and 

"TimeLength" to perform spectrum analysis on IQ signals collected over different time 

segments. Adjust the values of "Center" in the "Frequency" submenu and "Span" in the "BW" 

submenu to change the center frequency and analysis bandwidth of the spectrum; 

2. Use "FFTsize" to set the number of points for spectrum analysis, "Window" to select 

different window functions, "TraceDetector" to set different trace detectors, and 

"Intercept" to crop the displayed spectrum. When Intercept = 0.8, the transition band can 

be cropped. 
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Figure 27 Spectrum analysis of IQ data 

7.4 IQvT 

7.4.1 Procedure 

Click "IQvT" in the main settings area and enable "Analyze". Drag the red selection box "IQvT-P" 

in the Max Power vs. Time thumbnail, or adjust the values of "TimeStart" and "TimeLength". Then 

click "Auto Range" under "Graph" to perform time-domain analysis on IQ signals from different 

time segments. 

 

Figure 28 IQ Time-Domain Plot and Zoom 
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7.5 PvT 

7.5.1 Procedure 

Click "PvT" in the main settings area and enable "Analyze". Drag the red selection box "PvT-P" in 

the Max Power vs. Time thumbnail, or adjust the values of "TimeStart" and "TimeLength" to 

perform power-vs.-time analysis on IQ signals from different time segments. 

 

Figure 29 IQ Power-Time Plot and Zoom 

7.6 AM Demodulation 

As an example, demodulate an AM signal with a carrier frequency of 1 GHz, a power of -20 dBm, 

a modulation rate of 50 kHz and a modulation depth of 50%. 

7.6.1 Parameters description 

Only some of the important parameters are described here: the important parameters of the 

AM demodulation section are shown in Table below. 

Table 20 Description of AM Demodulation Parameters 

AudioFilter 

n Number of Filter Taps: The larger the number of taps, the steeper the 
filter’s transition band and the smaller the passband ripple. 

Fc Cutoff Frequency: 0<Fc<0.5. For example, if set to 0.25, a low-pass filter 
is applied to half of the bandwidth. 

As Stopband Attenuation: The higher the stopband attenuation, the 
stronger the suppression in the stopband. Attenuation is specified in 
dB. 

mu Fractional Sample Offset: It is recommended to use the default value. 
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7.6.2 Procedure 

1. Set "Center" to 1 GHz. Click the "Trigger" in the main settings area and set the "PreviewTime" 

to 3 ms; 

2. Click "Demod" in the main settings area and set the "Type" in the additional menu to AM; 

3. In the Max Power vs. Time thumbnail, drag the edge of the "Spectrum-P" selection box or 

increase the "TimeLength" in the "FFT" additional menu in the main settings area to expand 

the analysis range; 

4. Click "BW" in the main setting area, and click "Span▼", to decrease the analysis bandwidth. 

In this example, set the analysis bandwidth to 768kHz; 

5. Click the magnifying glass button "  " in the chart setting area, and select the area of 
interest in the "AM Waveform-P(%)" chart to perform the initial zoom. For PX series tablet 

instruments, users can further adjust the zoom box size using gestures: 

▪ Spreading or pinching two fingers horizontally allows for zooming in/out in the horizontal 

direction 

▪ Spreading or pinching two fingers vertically allows for zooming in/out in the vertical 

direction 

6. In the current configuration, the AM demodulation interface is shown in the figure below. 

The displayed content includes the spectrum of the modulated signal, the demodulated 

time-domain waveform, the audio spectrum, as well as parameters such as AM modulation 

depth, carrier power, modulation rate, SINAD, signal-to-noise ratio, and total harmonic 

distortion, allowing users to intuitively assess signal quality. 

 

Figure 30 AM Demodulation 

7.6.3 Audio analysis 

Can be used to test the demodulation sensitivity of an instrument. 

1. Refer to AM demodulation chapter Demodulation of AM signals; 

2. Click "Demod" in the main settings area, open "AudioAnalysis" in the submenu, and enable 

audio analysis. Check whether the audio analysis frequency matches the modulation rate. 

You can also measure the signal’s SINAD and Total Harmonic Distortion. 
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Figure 31 Audio analysis of AM demodulation 

7.7 FM Demodulation 

As an example, demodulate an FM signal with a carrier frequency of 1 GHz, a power of -20 dBm, 

a modulation frequency of 5 kHz and a frequency offset of 75 kHz. 

7.7.1 Parameters description 

Please refer to the AM demodulation parameter description chapter. When listening to FM 

broadcast signals, the FM demodulated signals can be low-pass filtered to reduce some of the 

high-frequency noise and make the listening sound purer. 

7.7.2 Procedure 

1. Set "Center" to 1GHz. Click the "Trigger" in the main settings area and set the "PreviewTime" 

to 3ms; 

2. Click "Demod" in the main settings area and set the "Type" in the additional menu to FM; 

3. In the Max Power vs. Time thumbnail, drag the edge of the "Spectrum-P" selection box or 

increase the "TimeLength" in the "FFT" additional menu in the main settings area to expand 

the analysis range; 

4. Click "BW" in the main setting area, and click "Span▼", to decrease the analysis bandwidth. 

In this example, set the analysis bandwidth to 384kHz 

5. Click the magnifying glass button "  " in the chart setting area, and select the area of 
interest in the "FM Waveform-P(%)" chart to perform the initial zoom. For PX series tablet 

instruments, users can further adjust the zoom box size using gestures: 

▪ Spreading or pinching two fingers horizontally allows for zooming in/out in the horizontal 

direction 

▪ Spreading or pinching two fingers vertically allows for zooming in/out in the vertical 

direction 

6. In the current configuration, the FM demodulation interface is shown in the figure below. 

The displayed content includes the spectrum of the modulated signal, the demodulated 

time-domain waveform, the audio spectrum, as well as parameters such as FM modulation 

frequency offset, carrier power, carrier frequency error, modulation rate, SINAD, signal-to-
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noise ratio, and total harmonic distortion, allowing users to intuitively assess signal quality. 

 

Figure 32 FM Demodulation 

7.7.3 Audio analysis 

After demodulating the FM signal, please refer to the Audio analysis section for audio analysis 

of the demodulated signal. 

7.8 DDC Digital Down Conversion 

Perform digital down conversion and resampling on the IQ data stream to generate sub-IQ 

streams for further spectrum analysis. The following example demonstrates DDC on a single-

tone signal at 1 GHz with a power of -20 dBm. 

7.8.1 Parameters description 

Only some of the important parameters are described here: some of the important parameters 

of the DDC digital down conversion are shown in Table below. 

Table 21 Description of DDC Digital Down Conversion Parameters 

State 

OffsetFreq Frequency shift of complex mixing, for >0, the spectrum is shifted 
to the right; for <0, the spectrum is shifted to the left. 

Decimate Setting the DDC extraction multiplier, i.e., the resampling rate. 

7.8.2 Procedure 

1. Set "Center" to 1 GHz and "Ref. Level" to 0 dBm. Adjust the range of "IQvT-P" in the Max 

Power vs. Time thumbnail. Select the IQ time-domain plot, click "Graph", and choose "Auto 

Range" in the Graph submenu; 

2. Click "DDC" in the main settings area. In the additional submenu, click "State On" to enable 

Channel 1. Set DDC1 channel parameters as follows: "Center" = 1.003 GHz, "OffsetFreq" = -

3 MHz, "Step" = 1 MHz, and "Decimate" = 3; 

3. Click "FFT" in the main settings area. In the additional submenu, select "DDC1" and enable 

"Analyze". Drag the red selection box "Spectrum-D1" in the Max Power vs. Time thumbnail, 
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or adjust "TimeStart" and "TimeLength" to perform spectrum analysis on the IQ sub-stream 

generated by DDC over different time segments; 

4. Click "IQvT" in the main settings area. In the additional submenu, select "DDC1" and enable 

"Analyze". Drag the red selection box "IQvT-D1" in the Max Power vs. Time thumbnail, or 

adjust "TimeStart" and "TimeLength" to perform spectrum analysis on the IQ sub-stream 

generated by DDC over different time segments; 

 

Figure 33 View the time-domain diagram of the IQ subflow under DDC 

5. In the main settings area, click "PvT", select "DDC1", and enable "Analyze". Then drag the red 

"PvT-D1" box in the Max Power vs. Time thumbnail, or adjust "TimeStart" and "TimeLength" 

to analyze the IQ sub-stream from DDC over different time segments. 

 

Figure 34 View the power-time graph of the IQ subflow under DDC  
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8. Using of the DET Mode 

This chapter describes in detail some of the parameters of the detector analysis mode and the 

measurement of pulse signals in this mode. 

8.1 Introduction to the General Parameters of DET Mode 

Only some of the important parameters are described here: some of the important parameters 

of the detector analysis mode are shown in Table 21. 

Table 22 Description of DET Mode Parameters 

Frequency 

LO Optimize Please refer to the parameter with the same name in the Introduction to 
the General Parameters of SWP Mode. 

Amplitude  

PreAmplifier Please refer to the parameter with the same name in the Introduction to 
the General Parameters of SWP Mode. GainStrategy 

IFGainGrade 

Atten 

AmpOffset 

IFAGC 

IFAGCTarget 

IFAGCGain Unit: dB. Returns the current IF AGC gain; positive values indicate gain, 
and negative values indicate attenuation. 

System  

RefCLKSource Please refer to the parameter with the same name in the Introduction to 
the General Parameters of SWP Mode. 

RefCLKOut 

8.2 Pulse Signal Measurement 

For example, a pulse modulated signal with a carrier frequency of 1 GHz, a power of -10 dBm, a 

pulse period of 80 us and a pulse width of 40 us is tested. 

8.2.1 Procedure 

1. Set "Center" to 1 GHz. Click "Single" in the menu bar to enable single-shot preview mode; 

2. Click "Graph" in the chart settings area, then click "Zoom" to enable zoom. Adjust the zoom 

region by dragging the selected area or by dragging the edges of the zoom box left or right; 

3. Select the zoomed plot, click "Graph" in the chart settings area, and choose "Marker Pair" to 

create two pairs of markers. Move M1R to the rising edge of a pulse, M1D to the falling edge 

of the same pulse, M2R to the rising edge of the pulse, and M2D to the rising edge of the 

next pulse. At this point, the values displayed for M1D and M2D in the upper-left corner of 

the zoomed plot correspond to the pulse width and pulse period, respectively. The duty 

cycle can be calculated using the following formula:  

DutyCycle =
PulseWidth(M1D)
PulsePeriod(M2D)
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Figure 35 Pulse Signal Period and Width Measurement 

8.3 Pulse Signal Detection (Option 72) 

If you purchase the Pulse Detection Option at a later date, please refer to the Pulse Detection 

Option section to apply for a license in order to use the function properly. 

8.3.1 Parameters description 

Only some of the important parameters are described here: The important parameters of the 

pulse signal detection section are shown in Table below. 

Table 23 Description of Pulse Signal Detection Parameters 

Pulse Det 

Threshold Pulse detection threshold, greater than the threshold value of the pulse 
signal will be determined as a valid pulse. 

Pulse Count Upper limit of pulse signal detection at current preview time. 

8.3.2 Procedure 

An example is the detection of a pulsed signal at 1 GHz, -20 dBm, with a pulse width of 40 us 

and a pulse period of 80 us. 

1. Set "Center" to 1 GHz and "Ref. Level" to 0 dBm; 

2. Click "BW" in the main settings area and adjust the "BW" value in the additional menu to set 

different analysis bandwidths. In this example, set "AnalysisBW" to 61.44 MHz; 

3. Click "Trigger" in the main settings area and set "PreviewTime" to 500 µs; 

4. Click "Pulse Det" in the main settings area to enable pulse detection. Drag the "Trigger.Level" 

in the power vs. time plot to set the pulse detection threshold, and adjust "Pulse Count" to 

set the maximum number of pulses detected within the current preview time; 

5. Click "Single" in the menu bar. The pulse detection results under the current configuration 

are shown in the figure below. From the figure, you can obtain parameters for each detected 

pulse signal, including Top Level (dBm), Base Level (dBm), Rise Time, Rise Edge, Fall Time, 

Fall Edge, Width, PRI, and Duty Cycle. Additionally, statistical parameters of the detected 
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pulses are available, such as Max, Min, and Mean PRI and PW, as well as PRI deviation (%) 

and PW deviation (%). 

 

Figure 36 Result of Pulse Detection 
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9. Using of the RTA mode 

This chapter provides a detailed introduction to certain parameters of the real-time spectrum 

analysis mode, the disabling of the probability density plot, and the measurement of Wi-Fi 

signals in this mode. 

9.1 Introduction to the General Parameters of RTA Mode 

Only some of the important parameters are described here: some of the important parameters 

of the real-time spectrum analysis mode are shown in Table below. 

Table 24 Description of RTA Mode Parameters 

Frequency 

LO Optimize Please refer to the parameter with the same name in the 
Introduction to the General Parameters of SWP Mode. 

Amplitude 

PreAmplifier Please refer to the parameter with the same name in the 

Introduction to the General Parameters of SWP Mode. GainStrategy 

IFGainGrade 

Atten 

AmpOffset 

IFAGC 

IFAGCTarget 

IFAGCGain Unit: dB. Returns the current IF AGC gain; positive values indicate 
gain, and negative values indicate attenuation. 

Sweep 

SWTMode Please refer to the parameter with the same name in the 

Introduction to the General Parameters of SWP Mode. Window 

System 

RefCLKSource Please refer to the parameter with the same name in the 
Introduction to the General Parameters of SWP Mode. 

RefCLKOut 

9.2 Probability Density Plot 

9.2.1 Parameters description 

Graph 

BitMap On: Enable probability density plot display 
Off: Disable probability density plot display 

Color Sky, Sea(Default), Jet, Cold, Hot, Gray 
Afterglow Increase: Extend the persistence of signal traces, suitable for 

capturing burst signals. 
Decrease: Speed up the refresh rate, suitable for tracking 
continuous signals. 
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9.2.2 Close Probability Density Plot 

Click "Graph" in the chart settings area, and in the pop-up window disable "BitMap" to turn off 

the probability density plot. 

 

Figure 37 Close Probability Density Plot 

9.3 WIFI Signal Measurement  

1. Connect the antenna to the RF input port "RFIN"; 

2. Set the "Center" frequency to 2.44 GHz, and increase the "Afterglow" value under the 

"Graph" submenu in the chart settings area to more clearly observe the Wi-Fi signal. 

 

Figure 38 Probability Density Plot of WIFI Signal  
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10. Digital Demodulation (Option 71) 

If you purchase the Pulse Detection option at a later date, please refer to the Digital 

Demodulation option section to apply for a license and a demodulation library in order to use 

the function properly. 

10.1 Parameters description 

Only some of the important parameters are described here: some of the important parameters 

are shown in Table below. 

Table 25 Description of Digital Demodulation Parameters 

Digital Demod  

SymbolRate The number of symbols per second transmitted by the signal, 
which should be filled in according to the symbol rate of the 
modulated signal to ensure correct demodulation at the receiving 
end 

ModType 2ASK, 2FSK, 4FSK, GMSK, BPSK, QPSK, 8PSK, 16QAM, 32QAM, 
64QAM, 128QAM, 256QAM 

FilterAlpha The roll-off rate of the filter used to limit the signal bandwidth in 
the transition band needs to be consistent with the roll-off 
coefficient at the transmitter to ensure efficient processing and 
correct demodulation of the signal by the demodulator 

Average number Increasing the number of averages reduces jitter in parameters 
such as EVMs 

10.2 Function Overview 

The initial interface of the digital demodulation mode consists of the modulated signal 

spectrogram, the demodulated constellation diagram, the eye diagram, and the demodulation 

parameters, including: error vector magnitude (EVM), magnitude error, phase error, frequency 

error, signal-to-noise ratio (SNR/MER), and a partially decoded bit sequence. The modulation 

quality of the signal is analyzed in depth, providing several error indicators to effectively assess 

the integrity and reliability of the signal in transmission. 

10.3 Procedure 

As an example, demodulation of a 64QAM signal at 1 GHz, -20 dBm, SymbolRate 1 MHz, 

FilterAlpha 0.35. 

1. Click "Mode" -> "Digital Demod"; 

2. Set the "Center" to 1 GHz and the "Ref.Level" to 0 dBm; 

3. Click "Demod" in the main setting area, set "ModType" to QAM64, "SymbolRate" to 1 MSPS, 

"FilterType" to 0.35, and "Average Count" to 10 in the additional menu, then click "Single" in 

the menu bar. MSPS, "FilterType" is set to 0.35, "Average Count" is set to 10, click "Single" in 

the menu bar, the demodulation result under the current configuration is shown in the figure 

below. The demodulation result under the current configuration is shown in the figure below. 
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Figure 39 64QAM Demodulation 
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11. Harmonic Analysis Mode 

11.1 Version Requirements 

1. Refer to the Viewing Instrument Information section to view the soft and firmware version; 

2. Ensure the version meets the following requirements: 

⚫ GUI Version: 4.3.55.24 or above 

⚫ API Version: 0.55.0 or above 

⚫ FPGA Version: 0.55.0 or above 

⚫ MCU Version: 0.55.0 or above 

3. If the GUI version does not meet the above requirements, please refer to the section on 

Software and Firmware Update to obtain the appropriate version of the host computer 

software. 

11.2 Enable Harmonic Analysis Function 

After updating the software and firmware to the required version, restart the host software, and 

click "Mode" -> "Harmonics" in the menu bar to use the harmonic analysis function normally. 

11.3 Parameters description 

Only some of the important parameters are described here: the important parameters of the 

harmonic analysis section are shown in Table below. 

Table 26 Description of Harmonic Analysis Parameters 

Frequency  

Center The center frequency of the fundamental signal. 

Span  

Span The measurement bandwidth for each harmonic. Range: 10 Hz to 
100 MHz. 

Amplitude  

Offset Adjust the position of the spectrum plot along the amplitude axis. 

Meas  

Harm Count Set the number of harmonics to measure and plot, up to 10. 

Meas Type Peak: Measure the peak power of the fundamental and each 
harmonic. 
ChannelPower: Measure the channel power of the fundamental 
and harmonics within their respective sweep bandwidths. 

Trace Type ClearWrite: Update the spectrum plot in real time, suitable for 
observing instantaneous signal changes. 
MaxHold: Hold the peak value of the displayed signal, suitable for 
capturing instantaneous peaks. 

PK Tracking On: Enable peak tracking of the fundamental signal, aligning its 
peak to the center frequency. 

THD Used to evaluate the distortion level of the signal. 
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11.4 Procedure 

An example is the measurement of the third harmonic of a 1 GHz, -20 dBm signal. 

1. Click "Frequency" in the main settings area and set "Center" to 1 GHz; 

2. Click "Amplitude" and set "Ref. Level" to -10 dBm; 

3. Click "Meas", set "Harm Count" to 3, and enable "PK Tracking". Keep other parameters at 

their default values; 

4. Click "Span" and set the "Span" to 10 MHz; 

5. Click "BW" and adjust "RBW" and "VBW" values to stabilize the trace. In this example, set 

RBW to 1 kHz and VBW to 100 Hz; 

6. The test results are shown in the figure below. The THD is displayed in the top-right corner 

of the spectrum plot. In the harmonic measurement table below, the frequencies, 

amplitudes, and differences from the fundamental of the second and third harmonics are 

listed. 

 

Figure 40 Measurement of Third Harmonic 
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12. Phase Noise Measurement Mode 

12.1 Version Requirements 

1. Refer to the Viewing Instrument Information section to view the soft and firmware version; 

2. Ensure the version meets the following requirements: 

⚫ GUI Version: 4.3.55.12 or above 

⚫ API Version: 0.55.58 or above 

⚫ FPGA Version: 0.55.17 or above 

⚫ MCU Version: 0.55.49 or above 

3. If the soft and firmware version does not meet the above requirements, please refer to the 

section on Software and Firmware Update to update. 

12.2 Enable Phase Noise Measurement Function 

After updating the software and firmware to the required version, restart the host software, and 

click "Mode" -> "Phase Noise" in the menu bar to use the phase noise measurement function 

normally. 

12.3 Parameters description 

Only some of the important parameters are described here: The important parameters for the 

phase noise measurement are shown in Table below. 

Table 27 Description of Phase Noise Measurement Parameters 

Frequency  

Center Set the center frequency of the fundamental. 

Start Offset Set the frequency offset start point: Range: 1 Hz to 9 MHz. 

Stop Offset Set the frequency offset stop point: Range: 10 Hz to 10 MHz. 

Threshold Set the threshold above which carriers will be identified. 

Meas  

RBW/Offset RBW Radio: (RBW of each frequency segment or start frequency 
of each frequency segment), range: 0.01 to 0.3. 

Detect Frame Detection Rate: The default configuration is recommended. 
If the test signal exhibits significant low-frequency jitter near the 
carrier, increase the frame detection rate in the near region to 
obtain more stable measurement results. 

Trace  

Average Set the number of averaging times for the trace. 

Smooth On: Enable trace smoothing. 
Off: Disable trace smoothing. 

Window Length Set the window length of the smoothing algorithm, range: 0 to 10%. 
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12.4 Procedure 

12.4.1 Phase Noise Measurement with Known Carrier Information 

As an example, the phase noise of a 1 GHz, 0 dBm signal is measured over an offset range of 

100 Hz to 10 MHz. 

1. Click "Frequency" in the main settings area. In the additional menu, set "Center" to 1 GHz, 

"Start Offset" to 100 Hz, and "Stop Offset" to 10 MHz. It is recommended to keep the other 

parameters at their default settings; 

2. If the test signal exhibits strong jitter near the carrier, click "Meas" in the main settings area. 

Then, in the additional menu, select "Detect". In the pop-up window, appropriately increase 

the frame detection rate for the corresponding frequency band to obtain more convergent 

measurement results; 

 

Figure 41 Pulse Signal Detection Settings 

3. If significant spurious components appear in the single-sideband phase noise spectrum, 

click "Trace" in the main settings area. Then, in the additional menu, select "Window Length" 

and gradually increase its parameter value to reduce the impact of spurious signals on the 

measurement results; 

4. The instrument will automatically perform phase noise measurements within the specified 

frequency offset range. The measurement results are shown below. In the phase noise 

measurement table at the bottom of the interface, information about the carrier as well as 

the phase noise values (dBc/Hz) at characteristic offset points can be obtained. 
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Figure 42 Result of Phase Noise Measurement 

12.4.2 Phase Noise Measurement with Unknown Carrier Information 

When the signal carrier parameters are unknown, it is recommended to follow the procedure 

below for phase noise measurement 

1. Click "Carrier". The instrument will automatically perform a full-band scan to search for and 

locate peak signals that exceed the carrier threshold, which will be used as the test carrier; 

2. After locating the carrier signal, refer to the Phase Noise Measurement with Known Carrier 

Information to set the start and stop frequency offsets, and perform the phase noise 

measurement. 
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13. Mapping Mode 

This chapter provides a detailed introduction to several key parameters of Map Mode and 

explains how to use this mode to perform automated measurements for generating signal 

distribution heat maps. 

13.1 Version Requirements 

Refer to the Viewing Instrument Information section to check the software and firmware 

versions, and ensure that the GUI version is 4.3.55.32 or later. 

13.2 Parameters description 

Only some key parameters are described here: the main settings of the mapping mode are 

shown in Table 28, and the controls in the mapping chart settings area are shown in Table 29. 

Table 28 Mapping Mode Main Settings Area Parameter Description 

Map 

Point Spacing Set the distance between two recording points, in meters. This 
takes effect only in "Manual" mode. 

Point Size Adjust the display radius of a single data point on the map. 
The larger the value, the larger the area occupied by the data point 
on the map. 

Point Border When enabled, a black outline border will be added to data points 
to enhance visual contrast and visibility against complex map 
backgrounds. 

Point Opacity Adjust the transparency of data point colors. The smaller the value, 
the lower the transparency. 

Table 29 Introduction to Map Chart Settings Area Controls 

Map 

Manual In the map interface, click the mouse or tap the touchscreen to 
capture measurement data at the current location and plot the data 
point on the map in real time. 

Auto This function is available when the built-in/external GPS is locked. 
The software automatically collects and plots data according to the 
distance specified by the "point spacing" setting. 

Select In the map interface, select or deselect existing measurement 
points. When a data point is selected, a pop-up window will display 
detailed measurement parameters (including frequency, integration 
bandwidth, power, peak value, occupied bandwidth, time, 
longitude, latitude, and altitude). 
Click the "Direction" button, a direction indicator line will be 
automatically generated next to the data point. Click and hold the 
data point to rotate it, and the direction line will rotate accordingly. 
The corresponding panel will update and display the current 
indicated angle in real time. 

Clear Points Clear all measurement data points plotted on the map. 

 Click " ", zoom in on the current map display scale. 

 Click " ", zoom out on the current map display scale. 
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 Click " ", enter distance measurement mode. Click sequentially on 
the map to display the actual distance between two consecutive 
points. Click the icon again to exit measurement mode. 
Click the "x" next to the measurement line to clear the current 
measurement trace, 

13.3 Procedure 

This section describes how to use a spectrum analyzer equipped with a built-in GNSS and an 

external antenna to generate signal distribution heat maps through automated measurements. 

1. Click "Mode" -> "Mapping" on the menu bar to enable the Map function; 

2. Refer to the Using the Bulit-in GNSS Module section to complete the GNSS module 

connection; 

3. Connect the antenna to the RF input port of the spectrum analyzer; 

4. Click "Map" in the main settings area, and set the "point spacing", as well as the size, border, 

and transparency of measurement points in the submenu; 

5. Click "Frequency" in the main settings area to set the "center frequency" to 2.13 GHz. Click 

"Span" to set the "sweep bandwidth" to 200 MHz. Click "Meas" and set the "center 

frequency" to 2.13 GHz and the "integration bandwidth" to 40 MHz; 

6. Drag and zoom the map in the interface to the current location. Click the "Auto" button in 

the chart settings area to start measurement. Then move the device, and the instrument will 

automatically collect and plot measurement points on the map according to the preset 

"point spacing"; 

7. Click "Select" in the chart settings area, and select an existing measurement point on the 

map. A floating information panel will display detailed parameters of the point, including 

frequency, integration bandwidth, power, peak value, occupied bandwidth, time, latitude, 

longitude, and altitude; 

8. Enable "Direction" in the measurement details panel. A direction indicator line will be 

automatically generated next to the data point. Click and hold the data point to rotate it, 

and the direction line will rotate accordingly. The corresponding panel will update and 

display the current indicated angle in real time; 

9. The channel power measurement result is displayed in the upper-right corner of the 

interface, and the measurement point information table is shown in the lower-right corner. 

Double-click the corresponding chart or table area to enlarge it, and double-click again to 

restore it.  
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14. MSCAN Mode 

14.1 Description of MSCAN Mode Functions 

MSCAN mode is an analysis mode based on a user-defined frequency band list for multi-

segment sequential sweeping. It is particularly suitable for fast preview and analysis of multi-

band signals. The interface of this mode includes the following key elements: 

1. Preview Diagram 

The preview diagram shows the composite spectrum of all configured frequency bands in the 

list. The red box highlights the spectrum corresponding to the selected frequency band in the 

list, allowing users to quickly locate and analyze the detailed signal characteristics of a specific 

band. 

2. Configuration List 

The table lists the configuration items for different frequency bands. Users can customize the 

measurement parameters for each band. Adjustable parameters include center frequency, 

span, reference level, dwell time, decimation factor, FFT size, number of detections, detector 

type, IFAGC, XPPS Trigger, IQ output, and window type. After the list configuration is 

completed, the device continuously acquires and displays spectrum data according to the 

defined settings. 

3. Spectrum and IQvT View 

Displays the spectrum and IQ time-domain view corresponding to the selected frequency band 

in the list configuration. 

14.2 Introduction to the General Parameters of MSCAN mode 

Table 30 Description of Preview Diagram Parameters 

Preview Diagram 

#x Center 
Display the center frequency corresponding to the selected frequency 
band in the sweep list. 

SweepTime Display the total time required for all frequency bands in the sweep list. 

Table 31 Description of Configuration List Parameters 

Configuration List 

# Index of each frequency band in the sweep list, range: [1, 128] 

Center (Hz) Set the center frequency for each frequency band 

Span (Hz) 
Set the analysis bandwidth for each band, where bandwidth = 101.526/ 
decimation factor 

Ref (dBm) Set the reference level for each band, range: [-100, 27] 

DwellTime (s) Set the dwell time of the device for each band 

Decimate Increase the decimation factor reduces the span, range: 2^n, n =1 to 12 

FFTSize Set the number of FFT points for each band, range: 2^n, n = 5 to 12 

DetectCount Number of sweeps performed by the device for each band 
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Detector 
Select the detector type for each band. Options: Sample, Positive 
Peak, Average, Negative Peak, Max Power, Raw Frame Detector, and 
RMS. 

IFAGC 
On: Adjusts the gain of signals within the band to keep the signal level 
within an appropriate range 

XPPStrigger 
On: The enabled band uses 1PPS trigger  
Off: Use Bus Trigger 

IQPlayBack 
On: Displays the IQ time-domain data of the enabled band in the IQ 
time-domain view 

Window 
Select the window type for each band. Options: B-Nuttall, Flat-Top, 
LowSideLobe, Rectangle and Kaiser. 

Insert Insert a new configuration band below the selected frequency band. 

Delete Delete the selected item. 

Import Import pre-saved configurations. 

Export Export the configuration list to the "/data" folder. 

14.3 Procedure 

14.3.1 Configuration Requirements 

Configure the list according to the data in the table below to acquire spectrum data for 

different frequency bands under different configurations. 

Index Configuration 

1 
Center: 500 MHz; Span: 50 MHz; FFTSize: 2048; Detector: PosPeak; Window: 
FlatTop 

2 
Center: 2.4 GHz; Span: 25 MHz; FFTSize: 1024; Detector: RMS; IQPlayBack: On; 
Window: Kaiser 

14.3.2 Operating Steps 

The following example uses a newly configured SAN series instrument with a 50 MHz analysis 

bandwidth option to perform the above configuration and observe the spectrum display. 

1. Click "Mode" -> "MSCAN" in the menu bar, and delete the default configuration; 

2. Double-click the parameter field corresponding to Band 1 and modify the settings as 

follows: Set "Center (Hz)" to 500 MHz, "Ref (dBm)" to 0 dBm, "Decimate" to 1, "FFTSize" to 2048, 

"Window" to FlatTop; 

3. Double-click the parameter field corresponding to Band 2 and modify the settings as 

follows: Set "Center (Hz)" to 2.4 GHz, "Ref (dBm)" to -20 dBm, "Decimate" to 2, "FFTSize" to 1024, 

enable "IQPlayBack", and set "Window" to Kaiser; 

4. At this point, the preview displays a combined spectrum of the two bands. The selected 

band in the list is highlighted with a red box in the preview. The corresponding spectrum analysis 

and IQ time-domain waveform (if IQ output is enabled for that band) are displayed 

simultaneously; 

5. Click the "Export" button to export the current configuration list data, or click "Import" to 

load a saved configuration. 
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Figure 43 Configuration List in MSCAN mode 
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15. Signal/Tracking Generator Function 
(Option 02) 

The built-in signal/tracking generator option can output single-tone signals, frequency sweep 

signals, and power sweep signals, and supports tracking generator functionality. This option is 

only available for all-new PXN series. 

15.1 Introduction to the General Parameters of the Signal Generator 

Table 32 Description of AUXS Mode Parameters 

RF Out On: Enables the signal source output 
Off: Disables the signal source output 

Mode Fixed Frequency mode, frequency sweep, power sweep, TG 

FixedPoint  

Center Set the frequency for single-tone and power sweep signals 

Level Set power for single-tone and frequency sweep signals 

FreqSweep  

Start Set the start frequency of the frequency sweep signal 

Stop Set the stop frequency of the frequency sweep signal 

Step Set the frequency step of the frequency sweep signal 

Dwell Time Set the dwell time of the frequency sweep signal 

PowerSweep  

Center Set the output signal center frequency 

Start Set the start power of the power sweep signal 

Stop Set the stop power of the power sweep signal 

Step Set the power step of the power sweep signal 

DwellTime Set the dwell time for sweep signals, effective in "PowerSweep" and 
"FrequencySweep" modes 

TG 

Output Power Track the amplitude of the tracking generator output signal. 

Save Reference Save the current measurement trace as a reference baseline. 

Show Reference Recall the saved reference trace for comparison and analysis 

Normalize Perform normalization based on the reference trace to eliminate 
system path loss, displaying only the frequency response 
characteristics of the device under test (DUT). 
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15.2 Instructions for Using the ASG Function 

The signal is output through the instrument’s RFOUT port, which can either provide an input 

signal to other devices or be connected via cable to the instrument’s own RF input port. The 

following example demonstrates a self-transmit-and-receive setup. 

15.2.1 Output a Single-Tone Signal 

1. Click "AUXS" -> "RF On" in the main settings area to enable the signal source option; 

2. In the "AUXS" submenu, set "Center" to 1 GHz and "Level" to -20 dBm to output a single-tone 

signal at 1 GHz with a power level of -20 dBm. 

 

Figure 44 AUXS Single-Tone Signal Output 

15.2.2 Output a Frequency Sweep Signal 

1. Click "AUXS" in the main setting area, set the "Mode" to Frequency Sweep, and enable "RF 

Output"; 

2. In the sweep signal parameter settings area, set Output Power to -20 dBm, Start Frequency 

to 3 GHz, Stop Frequency to 3.5 GHz, Frequency Step to 40 MHz, and Dwell Time to 8 ms; 

3. The built-in signal generator outputs a frequency sweep signal with a start frequency of 3 

GHz, a stop frequency of 3.5 GHz, a frequency step of 40 MHz, a dwell time of 8 ms, and an 

amplitude of -20 dBm. 
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Figure 45 AUXS Frequency Sweep Signal Output 

15.2.3 Output a Power Sweep Sigal 

1. Click "AUXS" in the main settings area, set the "Mode" to Power Sweep, and enable "RF 

Output"; 

2. In the power sweep signal parameter settings area, set “Center Frequency” to 1 GHz, “Start 

Power” to -40 dBm, “Stop Power” to -10 dBm, “Power Step” to 1 dBm, and “Dwell Time” to 

100 ms; 

3. The built-in signal generator outputs a power sweep signal with a frequency of 1 GHz, a 

start power of -40 dBm, a stop power of -10 dBm, a power step of 1 dBm, and a dwell time 

of 100 ms. 

15.2.4 Tracking Generator (TG) 

The tracking generator (TG) is a core function of a spectrum analyzer used for measuring the 

frequency response of devices under test (DUT). When the TG function is enabled, the RF 

output port of the spectrum analyzer generates a signal that is strictly synchronized with the 

current sweep frequency. 

1. Set the instrument’s “Center Frequency” and “Span” according to the operating frequency 

band of the device under test (DUT); 

2. Click “AUXS” → “RF On” in the main settings area, select “TG” as the mode to enable the 

tracking generator, and set an appropriate “Output Power” according to the DUT 

characteristics; 

3. Use a high-quality RF coaxial cable to directly connect the spectrum analyzer’s TG output 

port to the RF input port; 

4. After the trace on the screen becomes stable, press the “Through Calibration” button to 

save the measurement curve that includes system cable loss, and enable the normalization 

function to eliminate system errors from the cable and instrument (after normalization, the 

trace typically appears as a near 0 dB flat line); 
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5. Disconnect the through connection and insert the DUT between the TG output port and 

the RF input port. The trace displayed on the screen now represents the true frequency 

response of the DUT. 

 

Figure 46 Frequency response curve of a band-pass filter 
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16. Additional Functions 

This chapter briefly describes the IF outputs of the instrument, as well as the trigger function, 

the input of an external reference clock, and the remote control of the device. 

16.1 Description of Trigger Functions 

16.1.1 SWP Frequency Sweep Mode 

Trigger 

TriggerSource FreeRun, Ext.PerHop, Ext. PerSweep, Ext.PerProfile, InXpps.PerHop, 
InXpps.PerSweep, InXpps.PerProfile 

TriggerEdge RisingEdge, FallingEdge, DoubleEdge 

TriggerOut None. 
PerHop: outputs a trigger for each completed frame of analysis. 
PerSweep: outputs a trigger for each trace scan completed. 
PerProfile: outputs a trigger for each switching configuration. 

PulsePolarity Positive, Negative 

16.1.2 Fixed Frequency Point Mode for IQS, DET and RTA 

Trigger 

TriggerSource External, Bus, Level, Timer, DevSyncByExt, DevSyncBy1PPS, GNSS1PPS 

TriggerEdge RisingEdge, FallingEdge, DoubleEdge 

TriggerDelay Set the time to delay acquisition after triggering 

PreTrigger Set the time to collect in advance before triggering 

ReTrigger The instrument responds multiple times after capturing a trigger 

ReTrigger-On 

Count After a single trigger response, additional responses may be required. 

Period The time interval between multiple responses to a single trigger 
corresponds to the trigger period under the timer trigger mode. 

TriggerSource-Level 

Level Set the level trigger threshold. A signal exceeding the threshold indicates 
that the trigger condition is met. 

SafeTime Set the debounce safety time for the level trigger. 

TriggerSource-Timer 

Period Trigger period under the timer trigger mode 

Sync Not synchronized with the external trigger 
Synchronized with the external trigger’s rising edge 
Synchronized with the external trigger’s falling edge 
Single-shot synchronization with the external trigger’s rising edge 
Single-shot synchronization with the external trigger’s falling edge 
Synchronization with the GNSS-1PPS rising edge 
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Synchronization with the GNSS-1PPS falling edge 
Single-shot synchronization with the GNSS-1PPS rising edge 
Single-shot synchronization with the GNSS-1PPS falling edge 

16.2 IF Output Application Guide 

The frequency of the analog IF output signal is between 312.5 MHz ±  50 MHz. The center 

frequency of the analog IF output of each instrument can be viewed in the IF calibration file in 

the "/bin/CalFile" folder in the software installation directory. 

 

Figure 47 Check the IF Output Center Frequency on PXN Series Instruments 

16.3 External Reference Clock Input 

1. Refer to the interface description in the Quick Start Guide to input the external reference 

clock; 

2. In the main settings area, click "Next" -> "System", set the reference clock frequency 

"RefCLKFreq" to 10 MHz, and select "External" as the reference clock source 

"RefCLKSource". If the reference clock source displays "External", the switch is successful. 

If it reverts to "Internal" and an error message pops up, the switch has failed. In this case, 

click "Preset" to switch back to the internal clock. 
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Figure 48 Use an external 10 MHz reference clock 

16.4 Connecting and Operating Multiple Instruments Simultaneously 

A single window of the software can only control one instrument. To operate multiple 

instruments simultaneously, you can open multiple windows within the same software, with 

each window corresponding to a different instrument number. 

This section takes the simultaneous operation of two SA series instruments as an example. The 

specific steps are as follows: 

1. Correctly connect the two instruments to the host computer; 

2. Copy the calibration files corresponding to the two instruments into the "/bin/CalFile" 

folder in the software directory; 

3. Double-click the executable program in the "bin" folder to open the software and enable 

the instrument with device number 0; 

4. Go to the "configuration" folder in the software directory, open the "Setting.ini" text file, and 

change "DeviceNum=0" to "DeviceNum=1"; 

5. Double-click the software executable program again, and enable the instrument with 

device number 1 in the new window. 

Note: If only one instrument is connected for use later, reset "DeviceNum" in the 

"configuration/Setting.ini" file to 0, otherwise the software may not recognize the instrument 

correctly. 
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Figure 49 Operating two Instruments Simultaneously  
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17. Application for Options 

17.1 Pulse Detection Option 

17.1.1 Application for License 

1. Refer to the Viewing Instrument Information section to view the soft and firmware version; 

2. Ensure the version meets the following requirements: 

⚫ GUI Version: 4.3.55.6 or above 

⚫ API Version: 0.55.55 or above 

⚫ FPGA Version: 0.55.15 or above 

⚫ MCU Version: 0.55.32 or above 

3. If the soft and firmware version does not meet the above requirements, please refer to the 

section on Software and Firmware Update to update. 

4. Click "System" -> "About", take a screenshot of the entire software interface, and send it to 

the official technical support team to apply for the corresponding device license. 

17.1.2 License Placement 

1． Place the Pulse detection license for SA/NX Series instruments 

1) Copy the obtained Pulse Detection license to the "/bin/CalFile" folder of the software; 

2) Restart the software. In the menu bar, click "Mode" -> "Power Detection", then enable "Pulse 

Det" in the main settings area to use the pulse signal detection function. 

2． Place the Pulse detection license for PX Series instruments 

1) Extract the obtained "Option" folder and copy it to a USB flash drive; 

2) Click "File" -> "Exit" to quit the software operation interface; 

3) Insert the USB flash drive into the instrument's USB port. When the "Removable medium is 

inserted" prompt box pops up, click "OK"; 

4) Enter the "Option" folder, click the "Optional" icon. When the terminal prompts "The option 

has been successfully installed!!!", it indicates that the pulse license has been successfully 

placed; 

 

Figure 50 Install the Pulse Detection Option License 

5) Close the popup window and restart the software. In the menu bar, click "Mode" -> "Pulse 

Detection", then enable "Pulse Det" in the main settings area to use the pulse signal 

detection function. 
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17.2 Digital Demodulation Option 

17.2.1 Application for License and Digital Demodulation Library 

Refer to the license application for Pulse Signal Detection to apply for the corresponding 

license and digital demodulation library. 

17.2.2 License and Digital Demodulation Library Placement 

1． Place the Digital demodulation license and Library for SA/NX Series instruments 

1) Copy the "DigitalSigDemod.dll" demodulation library file into the "/bin" folder under the 

software directory; 

2) Copy the digital demodulation license into the "/bin/CalFile" folder under the software 

directory; 

3) Restart the software. In the menu bar, click "Mode" -> "Digital Demod" to enable and use the 

digital demodulation function. 

2． Place the Digital demodulation license and Library for PX Series instruments 

1) Refer to the Place the Pulse detection license for PX Series Instruments section, and click 

"Optional" icon to install the corresponding license and demodulation library; 

2) Close the popup window and start the software. In the menu bar, click "Mode" -> "Digital 

Demod" to use the digital demodulation function. 

17.2.3 AUXS Option 

For later purchases of the ASG option, the device must be returned for an upgrade. 
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18. Software and Firmware Update 

This section describes how to update the instrument’s software, FPGA, MCU, and Bus 

versions. 

18.1 Version Requirements 

1. Refer to the viewing instrument information section to check the software and firmware 

versions; 

2. For all instruments, ensure that the GUI version is 4.4.55.36 or above; 

3. If the software indicates that the update cannot be performed, please contact official 

technical support. 

18.2 Parameter Description 

Note: Displays the current and target versions of the software, FPGA, MCU, and Bus; 

Update Content: Provides detailed information about the changes in the target version; 

Update Notification: Sets whether to automatically pop up an update notification window 

when a new version is detected; 

Update Method: The update methods are described in the table below. 

Table 33 Update Method Description 

Update Method Description 

Online Download and install the latest software and firmware directly from 
the server. 

Default Update using the locally stored default update files. 

Local Manually select local update files to perform the update. 

18.3 Online Update 

1. Click "System" -> "Update" to enter the update interface; 

2. Check the "Update Notification" checkbox and ensure the device is connected to the 

internet. When the software starts or is running, if a new version is detected. The "Update" 

window will pop up automatically. You can also open this window by clicking "System" -> 

"Update"; 

3. Set the “Update Method” to Online. The system will then start downloading the update 

package, and the “Update” button will be temporarily disabled. After the package is 

successfully downloaded and parsed, detailed release notes will be displayed in the 

window, and the “Update” button will become enabled; 

4. Carefully compare the information between the current version and the target version, and 

review the new features and fix list. Once confirmed, click the “Update” button in the lower-

right corner; 
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Figure 51 Update Software and Firmware Online 

5. After clicking, the software will automatically exit and enter the upgrade process. Please 

keep the update window open until the progress bar completes and the software 

automatically restarts and returns to the main interface; 

6. Close the update information window, then click “System” → “About” in the menu bar to 

view the current firmware version of the instrument. 

18.4 Offline Update 

Download the latest software version from the company’s official website using the links below: 

▪ SA/NX Series Instruments: https://www.harogic.com/software-for-harogic-sa-nx-

series-spectrum-analyzer/  

▪ PX Series Instruments: https://www.harogic.com/software-for-haroglc-px-series-

spectrum-analyzer/ 

Taking the PX series instrument software and firmware update as an example, the offline 

update steps are as follows: 

1. Copy the downloaded PX series software installation package from the official website to 

a USB drive. Insert the USB drive into the instrument, and click "OK" in the pop-up 

"Removable medium is inserted" window; 

2. Click "System" -> "Update" to open the update window; 

3. Select "Local", click "Open" to choose the target software installation package, then click 

the "update" button at the bottom right; 

https://www.harogic.com/software-for-harogic-sa-nx-series-spectrum-analyzer/
https://www.harogic.com/software-for-harogic-sa-nx-series-spectrum-analyzer/
https://www.harogic.com/software-for-haroglc-px-series-spectrum-analyzer/
https://www.harogic.com/software-for-haroglc-px-series-spectrum-analyzer/
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Figure 52 Offline Software and Firmware Update 

4. The software will then automatically exit and enter the upgrade process. Please keep the 

update window open until the progress bar is complete and the software automatically 

restarts and returns to the main interface. 
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Appendix 

Appendix 1: Record File Format Description 

1.1 File Naming Format 

The file name consists of the last four digits of the device ID, the date and time (year, month, 

day, hour, minute, and second) at the start of recording, the part index, and the file suffix. 

For example: 0028_yyyymmdd_hhmmss_partx. suffix. 

Regardless of the total recording duration, all sub-files generated during the same recording 

session share the same date-time stamp in their names, which corresponds to the time when 

the recording started. 

1.2 Conversion of Structures into Byte Arrays 

The structures SWP_Profile_TypeDef, SWP_TraceInfo_TypeDef, IQS_Profile_TypeDef, 

IQS_StreamInfo_TypeDef, DET_Profile_TypeDef, DET_StreamInfo_TypeDef, RTA_Profile_TypeDef and 

RTA_FrameInfo_TypeDef are converted into byte arrays using the third-party tool msgpack. Therefore, 

these structures must also be decoded using msgpack during data reading. 
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Appendix 2: Standard Spectrum Analysis Mode 

The SWP record file uses a custom ".spectrum" format. The format description is shown in the 

following table. 

Table 1 Description of the Spectrum Format 

Byte Index Description 

0 to (71 + 10M) This section stores the file information and packet index. (1 MB = 1024 * 1024 
bytes) 

(72 + 10M) to 
(73+10M+length) 

This section stores the SWP_Profile_TypeDef, SWP_Profile_TypeDef (default 
configuration), and SWP_TraceInfo_TypeDef structures, where length 
represents the total number of bytes occupied by these three structures. 

(74 + 10M + structure 
length) to (end of file) 

This section stores the byte length of each data packet and the SWP data 
packets sequentially. Each SWP data packet mainly contains the frequency 
and power arrays, HopIndex, FrameIndex, and the MeasAuxInfo_TypeDef 
structure. 

 

Table 2 Detailed Description of the Spectrum Format 
 Byte Index Byte Count Data Type Field Name Endianness 

File Header  
Information 0 2 uint16_t File ID Big Endian 

2 1 uint8_t 0x8c Big Endian 

3 1 uint8_t 0x22 Big Endian 

4 1 uint8_t 0x52 Big Endian 

5 1 uint8_t 0x9b Big Endian 

6 1 uint8_t 0x00 Protocol Version Big Endian 

7 1 uint8_t 0x01 Protocol Version Big Endian 

8 4 uint32_t api Version Information Big Endian 

9-63 56  Reserved  

64 8 quint64 Number of Data Packets in 
Current File Big Endian 

72 10M = 10*1024*1024 QList Packet Index Big Endian 

Configuration 
Information 
msgpack 
Byte Array 

72+10M 2 uint16_t 

Configuration Information + 
Default Configuration 
Information + Trace Information 
Length (length) 

Big Endian 

74+10M  double StartFreq_Hz  

  double StopFreq_Hz 
 

  double CenterFreq_Hz 
 

  double Span_Hz 
 

  double RefLevel_dBm 
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 Byte Index Byte Count Data Type Field Name Endianness 

 
  double RBW_Hz 

 

  double VBW_Hz 
 

  double SweepTime 
 

  double TraceBinSize_Hz 
 

  int FreqAssignment 
 

  int Window 
 

  int RBWMode 
 

  int VBWMode 
 

  int SweepTimeMode 
 

  int Detector 
 

  int TraceFormat 
 

  int TraceDetectMode 
 

  int TraceDetector 
 

  uint32_t TracePoints 
 

  int TracePointsStrategy 
 

  int TraceAlign 
 

  int FFTExecutionStrategy 
 

  int RxPort 
 

  int SpurRejection 
 

  int ReferenceClockSource 
 

  double ReferenceClockFrequency 
 

  uint8_t EnableReferenceClockOut 
 

  int SystemClockSource 
 

  double ExternalSystemClockFrequency 
 

  int TriggerSource 
 

  int TriggerEdge 
 

  int TriggerOutMode 
 

  int TriggerOutPulsePolarity 
 

  uint32_t PowerBalance 
 

  int GainStrategy 
 

  int Preamplifier 
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 Byte Index Byte Count Data Type Field Name Endianness 

 
  uint8_t AnalogIFBWGrade 

 

  uint8_t IFGainGrade 
 

  uint8_t EnableDebugMode 
 

  uint8_t CalibrationSettings 
 

  int8_t Atten 
 

  int TraceType 
 

  int LOOptimization 
 

Default 
Configuration 
Information 
msgpack 
Byte Array 

Parameters Same as Configuration Information 

Trace 
Information 
msgpack 
Byte Array 

  int FullsweepTracePoints 
 

  int PartialsweepTracePoints 
 

  int TotalHops 
 

  uint32_t UserStartIndex 
 

  uint32_t UserStopIndex 
 

  double TraceBinBW_Hz 
 

  double StartFreq_Hz 
 

  double AnalysisBW_Hz 
 

  int TraceDetectRatio 
 

  int DecimateFactor 
 

  float FrameTimeMultiple 
 

  double FrameTime 
 

  double EstimateMinSweepTime 
 

  int DataFormat 
 

  uint64_t SamplePoints 
 

  uint32_t GainParameter 
 

  int DSPPlatform 
 

Data 
Packet 74+10M+length 4 int Data Packet Length Big Endian 

 8*N double*N Frequency Array 
(N = PartialsweepTrace Points) 

Platform 
Dependent 

 4*N float*N Power Array 
(N = PartialsweepTrace Points) 

Platform 
Dependent 

 4 int HopIndex Big Endian 

 



 

HAROGIC SAStudio4 User Guide 81 

 Byte Index Byte Count Data Type Field Name Endianness 

 
 4 int FrameIndex Big Endian 

 4 uint32_t MaxIndex Big Endian 

 4 float MaxPower_dBm Big Endian 

 2 int16_t Temperature Big Endian 

 2 uint16_t RFState Big Endian 

 2 uint16_t BBState Big Endian 

 2 uint16_t GainPattern Big Endian 

 4 uint32_t ConvertPattern Big Endian 

 8 double SysTimeStamp Big Endian 

 8 double AbsoluteTimeStamp Big Endian 

 4 float Latitude Big Endian 

 4 float Longitude Big Endian 

Next Data Packet 

The total number of 

packets can be found 

in the File Header 

 4 int Data Packet Length Big Endian 

   …  
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Appendix 3: Receiver/IQ Stream Mode 

The IQ record file uses the standard ".wav" format. The format description is shown in the 

following table. 

Table 3 Description of the WAV Format 

Chunk Description 

RIFF chunk  

RIFF chunk size  

File Format Type: "WAVE"  

fmt chunk  

fmt chunk size  

fmt chunk data  

prof chunk Format Chunk Identifier: "prof" 

prof chunk size Chunk Length 

prof chunk data This chunk stores the IQS_Profile_TypeDef, IQS_StreamInfo_TypeDef, 
DeviceInfo_TypeDef, and other related information. 

trig chunk Format Chunk Identifier: "trig" 

trig chunk size Chunk Length 

trig chunk data 

This chunk stores the IQS_TriggerInfo_TypeDef, DeviceState_TypeDef, 
IQS_ScaleToV, MaxPower_dBm, and MaxIndex for each IQ data packet, 
sequentially arranged. Each entry corresponds one-to-one with the 
packets in the data chunk. 

data chunk Format Chunk Identifier: "data" 

data chunk size Chunk Length 

data chunk data This chunk stores the IQ data packets in sequential order. 
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Table 4 Detailed Description of the iq.wav Format 
 Chunk Byte 

Index 
Byte Index 

within Chunk 

Byte 
Count 

Data 
Type 

Field Name Filed 
Description 

Endianness 

RIFF 
File Header 
Information  

RIFF 0 
 

4  Document Identifier "RIFF" 
 

 4 
 

4 uint32_t Data Length Chunk 
Length 

Litter Endian 

 8 
 

4  File Format Type "WAVE" 
 

fmt  
Chunk 
Description 

fmt 12 
 

4  Format Chunk Identifier "fmt" 
 

 16 
 

4 uint32_t Chunk Length 16 
Litter Endian 

 20 
 

2 uint16_t Audio Format Code 1 
Litter Endian 

 22 
 

2 uint16_t  
 2 

Litter Endian 

 24 
 

4 uint32_t Sampling Frequency  
Litter Endian 

 28 
 

4 uint32_t Byte Rate  
Litter Endian 

 32 
 

2 uint16_t Block Align  
Litter Endian 

 34 
 

2 uint16_t Bits per Sample  
Litter Endian 

File Header 
Information prof 36 

 
4  Format Chunk Identifier "prof" 

 

 40 
 

4 uint32_t Chunk Length  
Litter Endian 

 44 0 2 uint16_t File ID  
Big Endian 

 46 2 1 uint8_t 0x8c  
Big Endian 

 47 3 1 uint8_t 0x22  
Big Endian 

 48 4 1 uint8_t 0x52  
Big Endian 

 49 5 1 uint8_t 0x9b  
Big Endian 

 50 6 1 uint8_t 0x00 Protocol Version  
Big Endian 

 51 7 1 uint8_t 0x02 Protocol Version  
Big Endian 

 52 8 4 uint32_t api Version Information  
Big Endian 

 53-107 56   Reserved  
 

IQS_Profile 
Information 
msgpack 
Byte Array 

 108 64 2 uint16_t 
IQS_Profile + 
IQS_StreamInfo 
Structure Byte Length 

 
Big Endian 

 110 66  double CenterFreq_Hz  
 

  
 

 double RefLevel_dBm  
 

  
 

 uint32_t DecimateFactor  
 

  
 

 int RxPort  
 

  
 

 uint32_t BusTimeout_ms  
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 Chun
k 

Byte 
Index 

Byte Index  

within Chunk 

Byte 
Count 

Data 
Type 

Field Name Filed 
Description 

Endianness 

 
  

 
 int TriggerSource  

 

  
 

 int TriggerEdge  
 

  
 

 int TriggerMode  
 

  
 

 uint64_t TriggerLength  
 

  
 

 int TriggerOutMode  
 

  
 

 int TriggerOutPulsePolarity  
 

  
 

 double TriggerLevel_dBm  
 

  
 

 double TriggerLevel_SafeTime  
 

  
 

 double TriggerDelay  
 

  
 

 double PreTriggerTime  
 

  
 

 int TriggerTimerSync  
 

  
 

 double TriggerTimer_Period  
 

  
 

 uint8_t EnableReTrigger  
 

  
 

 double ReTrigger_Period  
 

  
 

 uint16_t ReTrigger_Count  
 

  
 

 int DataFormat  
 

  
 

 int GainStrategy  
 

  
 

 int Preamplifier  
 

  
 

 uint8_t AnalogIFBWGrade  
 

  
 

 uint8_t IFGainGrade  
 

  
 

 uint8_t EnableDebugMode  
 

  
 

 int ReferenceClockSource  
 

  
 

 double ReferenceClockFrequency  
 

  
 

 uint8_t EnableReferenceClockOut  
 

  
 

 int SystemClockSource  
 

  
 

 double ExternalSystemClockFrequency  
 

  
 

 double NativeIQSampleRate_SPS  
 

  
 

 uint8_t EnableIFAGC  
 

  
 

 int8_t Atten  
 

  
 

 int DCCancelerMode  
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 Chunk Byte 

Index 

Byte Index  

within 
Chunk 

Byte  

Count 

Data 
Type 

Field Name Filed 
Description 

Endianness 

 
  

 
 int QDCMode  

 

  
 

 float QDCIGain  
 

  
 

 float QDCQGain  
 

  
 

 float QDCPhaseComp  
 

  
 

 int8_t DCCIOffset  
 

  
 

 int8_t DCCQOffset  
      

  
 

 int LOOptimization  
 

IQS_ 
StreamInfo 
Structure 
Information 
msgpack 
Byte Array 

  
 

 double Bandwidth  
 

  
 

 double IQSampleRate  
 

  
 

 uint64_t PacketCount  
 

  
 

 uint64_t StreamSamples  
 

  
 

 uint64_t StreamDataSize  
 

  
 

 uint32_t PacketSamples  
 

  
 

 uint32_t PacketDataSize   

  
 

 uint32_t GainParameter   

DeviceInfo 
Structure 
Information 

  
 

2 uint16_t DeviceInfo Structure Byte Length  Big Endian 

  
 

8 uint64_t DeviceUID  Big Endian 

  
 

2 uint16_t Model  Big Endian 

  
 

2 uint16_t HardwareVersion  Big Endian 

  
 

4 uint32_t MFWVersion  Big Endian 

  
 

4 uint32_t FFWVersion  Big Endian 

Reserved 
  

 
     

IQS_ 
TriggerInfo 
Structure 
Information 

trig 400 
 

4  Chunk Identifier "trig"  

 404 
 

4 uint32_t Chunk Length  Litter Endian 

 408 
 

2 uint16_t IQS_TriggerInfo Structure Byte 
Length  Big Endian 

  
 

8 uint64_t SysTimerCountOfFirstDataPoint  Big Endian 

  
 

2 uint16_t InPacketTriggeredDataSize  Big Endian 

  
 

2 uint16_t InPacketTriggerEdges  Big Endian 

  
 

4*25 uint32_t StartDataIndexOfTriggerEdges[25]  Platform 
Dependent 

  
 

8*25 uint64_t SysTimerCountOfEdges[25]  Platform 
Dependent 
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 Chunk Byte Index Byte Index 

within Chunk 

Byte 
Count 

Data 
Type 

Field Name Filed 
Description 

Endianness 

 
  

 
25 int8_t EdgeType[25]  Platform 

Dependent 
DeviceState 
Structure 
Information 

  
 

2 uint16_t DeviceState Structure 
Byte Length  Big Endian 

  
 

2 int16_t Temperature  Big Endian 

  
 

2 uint16_t RFState  Big Endian 

  
 

2 uint16_t BBState  Big Endian 

  
 

8 double AbsoluteTimeStamp  Big Endian 

  
 

4 float Latitude  Big Endian 

  
 

4 float Longitude  Big Endian 

  
 

2 uint16_t GainPattern  Big Endian 

  
 

8 int64_t RFCFreq  Big Endian 

  
 

4 uint32_t ConvertPattern  Big Endian 

  
 

4 uint32_t NCOFTW  Big Endian 

  
 

4 uint32_t SampleRate  Big Endian 

  
 

2 uint16_t CPU_BCFlag  Big Endian 

  
 

2 uint16_t IFOverflow  Big Endian 

  
 

2 uint16_t DecimateFactor  Big Endian 

  
 

2 uint16_t OptionState  Big Endian 

Return 
Information   

 
4 float IQS_ScaleToV  Big Endian 

  
 

4 float MaxPower_dBm  Big Endian 

  
 

4 uint32_t MaxIndex  Big Endian 

Reserved 
  

 
     

Data Packet 
Data 25*1024*1024+400 

 
4  Chunk Identifier "data"  

 25*1024*1024+404 
 

4 uint32_t Chunk Length  Litter Endian 

 25*1024*1024+408 
 

64968  IQ Data Packet  Platform 
Dependent 

  
 

64968  IQ Data Packet  Platform 
Dependent 

  
 

  …  Platform 
Dependent 

  
 

  
The Nth IQ Data Packet, 
where N =  
(Chunk Length / 64968) 

 Platform 
Dependent 
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Appendix 4: Power Detection Mode 

The DET record file uses the standard ".wav" format, but it is not playable by third-party 

software. The format description is shown in the following table. 

Table 5 Description of the WAV Format 

Chunk Description 

RIFF chunk  

RIFF chunk size  

File Format Type: "WAVE"  

fmt chunk  

fmt chunk size  

fmt chunk data  

prof chunk Format Chunk Identifier: "prof" 

prof chunk size Chunk Length 

prof chunk data This chunk stores the IQS_Profile_TypeDef, IQS_StreamInfo_TypeDef, 
DeviceInfo_TypeDef, and other related information. 

trig chunk Format Chunk Identifier: "trig" 

trig chunk size Chunk Length 

trig chunk data 

This chunk stores the IQS_TriggerInfo_TypeDef, DeviceState_TypeDef, 
IQS_ScaleToV, MaxPower_dBm, and MaxIndex for each IQ data packet, 
arranged sequentially. Each entry corresponds one-to-one with the 
packets in the data chunk. 

data chunk Format Chunk Identifier: "data" 

data chunk size Chunk Length 

data chunk data This chunk stores the IQ data packets in sequential order. 
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Table 6 Detailed Description of the iq.wav Format 
 Chunk Byte 

Index 
Byte Index 

within Chunk 

Byte 
Count 

Data Type Field Name Filed 
Description 

Endianness 

RIFF 
File Header 
Information 

RIFF 0  4  Document Identifier "RIFF"  

 4  4 uint32_t Data Length Chunk Length Litter Endian 

 8  4  File Format Type "WAVE"  

fmt 
Format 
Chunk 
Structure 
Description 

fmt 12  4  Format Chunk Identifier "fmt "  

 16  4 uint32_t Chunk Length 16 Litter Endian 

 20  2 uint16_t Audio Format Code 1 Litter Endian 

 22  2 uint16_t Number of Channels 2 Litter Endian 

 24  4 uint32_t Sampling Frequency  Litter Endian 

 28  4 uint32_t Byte Rate  Litter Endian 

 32  2 uint16_t Block Align  Litter Endian 

 34  2 uint16_t Bits per Sample  Litter Endian 

File Header 
Information prof 36  4  Format Chunk Identifier "prof"  

 40  4 uint32_t Chunk Length  Litter Endian 

 44 0 2 uint16_t File ID  Big Endian 

 46 2 1 uint8_t 0x8c  Big Endian 

 47 3 1 uint8_t 0x22  Big Endian 

 48 4 1 uint8_t 0x52  Big Endian 

 49 5 1 uint8_t 0x9b  Big Endian 

 50 6 1 uint8_t 0x00 Protocol Version  Big Endian 

 51 7 1 uint8_t 0x04 Protocol Version  Big Endian 

 52 8 4 uint32_t api Version Information  Big Endian 

 53-107 56   Reserved   

DET_Profile 
Structure 
Information 
msgpack 
Byte Array 

 108 64 2 uint16_t 
DET_Profile + 
DET_StreamInfo  
Structure Byte Length 

 Big Endian 

 110 66  double CenterFreq_Hz   

    double RefLevel_dBm   

    uint32_t DecimateFactor   

    int RxPort   

    uint32_t BusTimeout_ms   

    int TriggerSource   
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 Chun
k 

Byte  

Index 

Byte Index 

within Chunk 

Byte 
Count 

Data 

Type 

Field Name Filed 
Description 

Endianness 

 
    int TriggerEdge   

    int TriggerMode   

    uint64_t TriggerLength   

    int TriggerOutMode   

    int TriggerOutPulsePolarity   

    double TriggerLevel_dBm   

    double TriggerLevel_SafeTime   

    double TriggerDelay   

    double PreTriggerTime   

    int TriggerTimerSync   

    double TriggerTimer_Period   

    uint8_t EnableReTrigger   

    double ReTrigger_Period   

    uint16_t ReTrigger_Count   

    int Detector   

    uint16_t DetectRatio   

    int GainStrategy   

    int Preamplifier   

    uint8_t AnalogIFBWGrade   

    uint8_t IFGainGrade   

    uint8_t EnableDebugMode   

    int ReferenceClockSource   

    double ReferenceClockFrequency   

    uint8_t EnableReferenceClockOut   

    int SystemClockSource   

    double ExternalSystemClockFrequency   

    int8_t Atten   

    int DCCancelerMode   

    int QDCMode   

    float QDCIGain   
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 Chunk Byte 

Index 

Byte Index 

with Chunk 

Byte 
Count 

Data 
Type 

Field Name Filed 
Description 

Endianness 

 
    float QDCQGain   

    float QDCPhaseComp   

    int8_t DCCIOffset   

    int8_t DCCQOffset   

    int LOOptimization   

DET_ 
StreamInfo 
Structure 
Information 
msgpack 
Byte Array 

    uint64_t PacketCount   

    uint64_t StreamSamples   

    uint64_t StreamDataSize   

    uint32_t PacketSamples   

    uint32_t PacketDataSize   

    double TimeResolution   

    uint32_t GainParameter   

Reserved 
        

IQS_ 
TriggerInfo 
Structure 
Information 

trig 400  4  Format Chunk Identifier "trig"  

 404  4 uint32_t Chunk Length  Litter Endian 

 408  2 uint16_t IQS_TriggerInfo Structure Byte Length  Big Endian 

   8 uint64_t SysTimerCountOfFirstDataPoint  Big Endian 

   2 uint16_t InPacketTriggeredDataSize  Big Endian 

   2 uint16_t InPacketTriggerEdges  Big Endian 

   4*25 uint32_t StartDataIndexOfTriggerEdges[25]  Platform 
Dependent 

   8*25 uint64_t SysTimerCountOfEdges[25]  Platform 
Dependent 

   25 int8_t EdgeType[25]  Platform 
Dependent 

MeasAuxInfo  
Structure 
Information 

   2 uint16_t MeasAuxInfo Structure Byte Length  Big Endian 

   4 uint32_t MaxIndex 
 

Big Endian 

   4 float MaxPower_dBm 
 

Big Endian 

   2 int16_t Temperature 
 

Big Endian 

   2 uint16_t RFState 
 

Big Endian 

   2 uint16_t BBState 
 

Big Endian 

   2 uint16_t GainPattern 
 

Big Endian 

   4 uint32_t ConvertPattern 
 

Big Endian 
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 Chunk Byte Index Byte Index 

within Chunk 

Byte 
Count 

Data 

Type 

Field Name Filed 
Description 

Endianness 

 
   8 double SysTimeStamp 

 
Big Endian 

   8 double AbsoluteTimeStamp 
 

Big Endian 

   4 float Latitude 
 

Big Endian 

   4 float Longitude 
 

Big Endian 

 
   4 float ScaleToV  Big Endian 

Reserved 
        

Data 
Packet Data 25*1024*1024+400  4  Format Chunk Identifier "data"  

 25*1024*1024+404  4 uint32_t Chunk Length  Litter Endian 

 25*1024*1024+408  64968  DET Data Packet  Platform 
Dependent 

   64968  DET Data Packet  Platform 
Dependent 

     …  Platform 
Dependent 

     
The Nth DET Data Packet, 
where N =  
(Chunk Length / 64968) 

 Platform 
Dependent 
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Appendix 5: Real-Time Spectrum Analysis Mode 

The RTA record file uses a custom ".rtspectrum" format. The format description is shown in 

the following table. 

Table 7 Description of the rtspectrum Format 

Chunk Description 

0 to (71+10M) This section stores the file information and packet index. (1 MB = 1024 × 1024 
bytes) 

(72+10M) to (73+10M+ length) This section stores the RTA_Profile_TypeDef and RTA_FrameInfo_TypeDef 
structures, where length represents the total number of bytes occupied by 
these structures. 

(74+10M+ length) to (end of file) This section stores the byte length of each data packet and the RTA data 
packets sequentially. Each RTA data packet mainly contains the 
SpectrumStream array, RTA_PlotInfo_TypeDef, RTA_TriggerInfo_TypeDef, 
and MeasAuxInfo_TypeDef structures. 

 

Table 8 Detailed Description of the rtspectrum Format 
 Byte Index Byte Count Data Type Field Name Endianness 

File Header 
Information 0 2 uint16_t File ID Big Endian 

2 1 uint8_t 0x8c Big Endian 

3 1 uint8_t 0x22 Big Endian 

4 1 uint8_t 0x52 Big Endian 

5 1 uint8_t 0x9b Big Endian 

6 1 uint8_t 0x00 Protocol Version Big Endian 

7 1 uint8_t 0x03 Protocol Version Big Endian 

8 4 uint32_t api Version Information Big Endian 

9-63 56  Reserved  

64 8 quint64 Number of Data Packets in Current File Big Endian 

72 10M=10*1024*1024 QList Packet Index Big Endian 

Configuration 
Information 
msgpack 
Byte Array 

72+10M 2 uint16_t Configuration Information +  
Trace Information Length (length) Big Endian 

74+10M  double CenterFreq_Hz 
 

  double RefLevel_dBm 
 

  double RBW_Hz 
 

  double VBW_Hz 
 

  int RBWMode 
 

  int VBWMode 
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 Byte Index Byte Count Data Type Field Name Endianness 

 
  uint32_t DecimateFactor 

 

  int Window 
 

  int SweepTimeMode 
 

  double SweepTime 
 

  int Detector 
 

  int TraceDetectMode 
 

  uint32_t TraceDetectRatio 
 

  int TraceDetector 
 

  int RxPort 
 

  uint32_t BusTimeout_ms 
 

  int TriggerSource 
 

  int TriggerEdge 
 

  int TriggerMode 
 

  double TriggerAcqTime 
 

  int TriggerOutMode 
 

  int TriggerOutPulsePolarity 
 

  double TriggerLevel_dBm 
 

  double TriggerLevel_SafeTime 
 

  double TriggerDelay 
 

  double PreTriggerTime 
 

  int TriggerTimerSync 
 

  double TriggerTimer_Period 
 

  uint8_t EnableReTrigger 
 

  double ReTrigger_Period 
 

  uint16_t ReTrigger_Count 
 

  int GainStrategy 
 

  int Preamplifier 
 

  uint8_t AnalogIFBWGrade 
 

  uint8_t IFGainGrade 
 

  uint8_t EnableDebugMode 
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  int ReferenceClockSource 

 

  double ReferenceClockFrequency 
 

  uint8_t EnableReferenceClockOut 
 

  int SystemClockSource 
 

  double ExternalSystemClockFrequency 
 

  int8_t Atten 
 

  int DCCancelerMode 
 

  int QDCMode 
 

  float QDCIGain 
 

  float QDCQGain 
 

  float QDCPhaseComp 
 

  int8_t DCCIOffset 
 

  int8_t DCCQOffset 
 

  int LOOptimization 
 

Trace 
Information 
msgpack 
Byte Array 

  double StartFrequency_Hz 
 

  double StopFrequency_Hz 
 

  double POI 
 

  double TraceTimestampStep 
 

  double TimeResolution 
 

  double PacketAcqTime 
 

  uint32_t PacketCount 
 

  uint32_t PacketFrame 
 

  uint32_t FFTSize 
 

  uint32_t FrameWidth 
 

  uint32_t FrameHeight 
 

  uint32_t PacketSamplePoints 
 

  uint32_t PacketValidPoints 
 

  uint32_t MaxDensityValue 
 

  uint32_t GainParameter 
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Data Packet 74+10M+ length 4 int Data Packet Length 
Big Endian 

 N uint8_t *N SpectrumStream Array 
Platform 
Dependent 

 4 float ScaleTodBm 
Big Endian 

 4 float OffsetTodBm 
Big Endian 

 8 uint64_t SpectrumBitmapIndex 
Big Endian 

 8 uint64_t SysTimerCountOfFirstDataPoint 
Big Endian 

 2 uint16_t InPacketTriggeredDataSize 
Big Endian 

 2 uint16_t InPacketTriggerEdges 
Big Endian 

 4*25 uint32_t StartDataIndexOfTriggerEdges [25] 
Platform 
Dependent 

 8*25 uint64_t SysTimerCountOfEdges [25] 
Platform 
Dependent 

 25 int8_t EdgeType [25] 
Platform 
Dependent 

 4 uint32_t MaxIndex 
Big Endian 

 4 float MaxPower_dBm 
Big Endian 

 2 int16_t Temperature 
Big Endian 

 2 uint16_t RFState 
Big Endian 

 2 uint16_t BBState 
Big Endian 

 2 uint16_t GainPattern 
Big Endian 

 4 uint32_t ConvertPattern 
Big Endian 

 8 double SysTimeStamp 
Big Endian 

 8 double AbsoluteTimeStamp 
Big Endian 

 4 float Latitude 
Big Endian 

 4 float Longitude 
Big Endian 

Next Data 
Packet 
(The total 
number of 
packets can be 
found in the 
File Header) 

 4 int Data Packet Length 
Big Endian 

   … 
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